Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
GELÖST | TWRP flashen auf SM G973F/DS (beyond1lte)
#11
(06.01.2024, 12:33)Starfox schrieb: TWRP lässt sich schon flashen mit Odin.

Ja, das funktioniert sicher irgendwie, auch beim S10! Hier wird es gezeigt Video

Hier wird auch wieder zusammen mit TWRP eine vbmeta geflasht, die kann tatsächlich in Odin unter CP eingefügt werden.

Auch zu sehen eine spezielle Tastenkombi beim TWRP Start, wo auch VolDown gedrückt wird und danach etappenweise einzelne Tasten losgelassen werden. Hier werden die Tastenkombi für aus und sofort danach ins recovery booten kombiniert, sehr clever!

Ich muss noch heraus finden, ob nach einer TWRP-Installation das Stock-Android überhaupt gestartet werden kann. Vllt. ist genau das der Punkt, wie mit TRWP eine vbmeta geflasht werden muss oder nicht.

Oder aber, ob das Stock-Android nicht gestartet werden darf sondern sofort nach dem TWRP Start LOS installiert werden muss (was ja der eigentliche Plan ist).

Nachtrag: Ja, Stock Android funktioniert auch mit TWRP, im Video wirds gezeigt!
Welche vbmeta wird benötigt?
Antworten
#12
Hier ist die Install Anleitung zu TWRP.

https://xdaforums.com/t/recovery-officia...s.4180287/

Es wird wohl eine VBMeta benötigt die disabled ist, also nicht das Recovery/Betriebssystem verzifiziert.
Antworten
#13
Jameinegütedaisseja!
avb disabled vbmeta
Die Erkenntnis kam jetzt leider zu spät.
Hatte zwischenzeitlich mit Odin TWRP und der vbmeta von LOS geflasht.
TWRP ist endlich drauf. 
Aber: Danach einen Systemstart ins Stockandroid probiert -> Bootloop.

Werde jetzt warten müssen, bis sich der Akku leergebootloopt hat. 
Dann entweder neuer Versuch mit der hier verlinkten vbmeta
oder gleich LOS drauf ...

Nachtrag:
Nach ein paar Stunden war der volle Akku leergeloopt.
Vorsichtshalber den nächsten Startversuch ins TRWP mit nur kleinster Akkuladung gemacht.
Der folgende Bootloop nach Mißerfolg war somit in 5 min erledigt, 
hatte vergessen das USB-Kabel gemäß den Anleitungen anzustecken, lag vielleicht daran.
Mit Kabel bootete dann endlich TWRP.

(Einen Versuch mit TWRP und der  avb disabled vbmeta von der TWRP Homepage habe ich nicht mehr gemacht und auch nicht versucht damit ins Stock-Android zu booten, 
der eigentliche Plan war ja auch LOS zu installieren)


Exclamation

LOS ist installiert !! 


Speicherkarten-Installationsmethode mit TWRP:
Hatte zuvor eine MicroSD nur mit der LOS-Installationsdatei.zip ins Handy gemacht.


In TWRP dann mit etwas mehr Akkuladung endlich LOS von der MicroSD installiert.
Ein Fehler ploppte auf. Sinngemäß `unzulässiges Argument`,
kein `done`.
Dann war das Handy (am Kabel, Ladespannung lag permanent an) zunächst für mehrere Minuten tot, schwarzer Bildschirm, keine Tastenkombi, keine Taste funktionierte. Keine Ladeanzeige mit Akkustand.
Nix.

Aber,
nach weiteren Minuten und schwarzem Bildschirm funktionierte der Power Button wieder und das Handy startete ins LOS. 
Bisher funktioniert LOS trotz der Fehlermeldung am Ende des Installationsprozesses.


So eine bucklige Installation hatte ich noch nie! 
Meine anderen beiden Galaxy ließen sich, vom Erstversuch abgesehnen, problemlos auf TWRP, LOS sowie LOSmicroG umstellen.

Ich habe vieles falsch gemacht. Auch andere werden darüber stolpern. Man muss aber nicht immer die selben Fehler machen! 


Eine Fehlerliste:

-Heimdall produzierte einen eingefrorenen Downloadmode und Fehler. Das Device wurde danach nicht mehr erkannt. Es ließ sich aber, nachdem der Bildschirm nach etwa einer halben Stunde wieder schwarz war, im neuen Versuch die Stockfirmware (alle Module) von samfw mit Odin drüberflashen, was die Sache rettete, das Handy wieder reparierte, für neue Versuche.
-Der Versuch TWRP zu flashen, um hinterher wieder das Stockandroid testweise weiter zu verwenden, klappte nicht. Die avb-disabled-vbmeta von der TWRP-Seite hätte zusammen mit TWRP geflasht werden müssen. Habe ich aber nicht mehr probiert.
-Nach dem flashen die Tastenkombination nicht hinbekommen, um ins geflashte Recovery zu booten. Zuvor auch Kabel zum PC vergessen. Startet dann wohl nie ins Recovery. Außerdem sieht der Recoverystart anfangs aus wie ein Systemstart, Tasten nicht loslassen, es dauert eine Weile.
-Wenn das Recovery zu sehen ist, Lineage direkt installieren, am besten von einer Speicherkarte, wo die lineage.zip vorher draufgekopiert wurde. Das ist sehr einfach. Das Handy mit dem neuen Recovery ins alte Stockandroid zu starten unterlassen. Kann klappen, kann aber in bootloops oder freezes enden.
-Wenn beim booten dann ewig der Samsung-Schriftzug zu sehen ist, warten, es kann Minuten dauern bis das neue System erstmals startet.

Interessant:
TWRP wurde nach der LOS-Installation auch bei diesem Galaxy nicht überschrieben, obwohl die .zip ja ein Recovery.img enthält.
Um mit dem funktionierenden Lineage einfach ins Recovery zu gelangen, anstatt der fizzeligen Tastenkombi lieber das erweiterte Ausschaltmenü in den Handyeinstellungen aktivieren. Damit ist über Neustart ein Start ins Recovery oder ins System möglich.

So, mir reichts erstmal! Wink
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] S10 SM G973F VBMETA & Lineageos 20 Frage Starfox 4 1.204 10.01.2024, 16:12
Letzter Beitrag: Starfox
  [LineageOS] [GELÖST] SM-G800F (S5Mini) nach Update: Booten stoppt nach PIN-Eingabe rwxxwr 6 2.150 24.08.2023, 16:23
Letzter Beitrag: wowi63
  [APP] SeedVault zur Wiederherstellung nach Flashen brauchbar? FrankD 5 5.842 27.02.2023, 22:06
Letzter Beitrag: allibo
  A52 4G - nach Systm > Updater > Installieren endlosboot in TWRP otto171 18 5.384 12.02.2023, 20:39
Letzter Beitrag: modder0815
  Samsung S7 G930F LineageOS installieren >gelöst< LinuxPaul 11 8.025 17.10.2022, 09:57
Letzter Beitrag: db91595

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste