Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LinOS-Installation mit neuestem TWRP - Bootloop
#1
Hallo zusammen,
habe gerade auf mein Galaxy A40 das passende LineageOS17.1 geflasht (und auch die GApps-for-Android), hänge jetzt aber in einer Boot-Schleife (nur über TWRP wieder ausschaltbar). Vielleicht habe ich folgendes falsch gemacht:
Die TWRP-Version ist ziemlich neu, 3.3.1-0.
Ich habe "installieren" gewählt, um das LinOS-Image von SD-Karte aus zu flashen. Bei älteren TWRP-Versionen ging es dann direkt los (nach betätigen des Schiebereglers), hier werde ich aber jetzt gefragt, auf welche Partition gebrannt werden soll: boot, system...
Ich habe nur "System" ausgewählt.
LinOS und die GApps werden ohne Fehlermeldung gebrannt.
Nach Wipe Dalvik und Reboot hänge ich dann aber in der Schleife...
Hätte ich noch eine andere Partition mit auswählen müssen?
Danke für jeden Hinweis!
Antworten
#2
(11.07.2020, 13:45)dosludwig schrieb: habe gerade auf mein Galaxy A40 das passende LineageOS17.1 geflasht (und auch die GApps-for-Android), hänge jetzt aber in einer Boot-Schleife


Welches Build von
LOS 17.1 (eventuell sogar Generic System Image - GSI)
und
TWRP 3.3.1-0
hast Du geflasht?

Offiziell wird das Galaxy A40 SM-A405FN/DS weder von LOS noch TWRP unterstützt.
Antworten
#3
(11.07.2020, 19:20)linsam schrieb:
(11.07.2020, 13:45)dosludwig schrieb: habe gerade auf mein Galaxy A40 das passende LineageOS17.1 geflasht (und auch die GApps-for-Android), hänge jetzt aber in einer Boot-Schleife


Welches Build von
LOS 17.1 (eventuell sogar Generic System Image - GSI)
und
TWRP 3.3.1-0
hast Du geflasht?

Offiziell wird das Galaxy A40 SM-A405FN/DS weder von LOS noch TWRP unterstützt.

Das TWRP ist die Datei TWRP_A40_A405FN_V3_BTB8_SAM.tar, passend zu meinem StockROM BTB8 (was ich extra vorher per Odin neu geflasht hatte, da eine neuer Version vorhanden war).
Das Image von LineageOS ist lineage-17.1-20200607-UNOFFICIAL-treble_arm64_avN.img - passt das nicht?

Danke auch für den Hinweis, dass LineageOS für das A40 nicht offiziell unterstützt wird. Ich überlege, jetzt doch beim StockRom zu bleiben aus verschiedenen Gründen...
Antworten
#4
Beim flashen eines Image muss immer angegeben werden auf welche Partition das geflasht werden soll.
Bei einer ZIP steht das in dieser ZIP drin wo welcher Teil hin kommt.
Die ROM von LOS auf der Downloadseite sind deshalb ZIP.



i9505 mit LOS17.1
Antworten
#5
(11.07.2020, 19:48)dosludwig schrieb: Das Image von LineageOS ist lineage-17.1-20200607-UNOFFICIAL-treble_arm64_avN.img - passt das nicht

Ich kenne das GSI-Image nicht im Detail.
Ich fragte, weil die GSI-Installation u. a. eine andere Dateiendung (.img) verwendet als das klassische LOS 17.1 Image (.zip)

Hast Du auch vor der GSI-Installation schön brav diese Partitionen gewiped?
/Dalvik Cache
/System
/Data
/Cache


Hast Du nach der GSI-Installation unmittelbar danach die GApps-for-Android.zip per TWRP 3.3.1-0 installiert?

Erst die TWRP Version 3.4.0-0 ist so richtig kompatibel mit LOS 17.1. Wie sich's beim GSI-Build verhält weiß ich noch nicht.
N.B. Für die offiziellen LOS 17.1 Builds (.zip) bietet sich "Lineage Recovery" an.


(11.07.2020, 19:48)dosludwig schrieb: Ich überlege, jetzt doch beim StockRom zu bleiben aus verschiedenen Gründen...

Das A40 StockRom Android 10 mit Security patches Mai 2020 ist relativ frisch und wird noch jeden Monat aktualisiert.

Da Du mit LOS 17.1 auch "GApps-for-Android" verwenden würdest, ist die Überlegung "doch beim StockRom zu bleiben" nachvollziehbar.
Es besteht ja die Möglichkeit des Debloaten. Schau mal - hier jemand etwa 90 Pakete deaktiviert:
(NON-ROOT) DEBLOAT SAMSUNG A40 (about 90 packages disable)
Antworten
#6
Die GooglePlayServices braucht man ja leider für die Corona-App... (bin jahrelang ohne ausgekommen, mit LInOS).
Aber Deine anderen Hinweise bzgl. TWRP und LinOS werde ich für später mal beherzigen, vielen Dank!
Danke auch für den Debloat-Tip! Da ich ja dank der Hinweise oben ja auch mit Magisk gerootet habe, werde ich damit mal mein Debloat-Glück probieren.
Noch mal allen vielen Dank für die Tips + Links!
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Sasmung S 5 Bootloop Neuinstallation mit Lineageos frozy 2 676 25.09.2020, 18:16
Letzter Beitrag: frozy
  TWRP kann Data/Storage nicht entschlüsseln derkon 7 1.238 25.08.2020, 09:39
Letzter Beitrag: llluuuzzziii
  Bootloop nach Installation von LOS17.1 membro 7 983 24.08.2020, 00:11
Letzter Beitrag: llluuuzzziii
Smile TWRP bleibt nicht dauerhaft TheAl 11 2.007 25.07.2020, 17:03
Letzter Beitrag: llluuuzzziii
  LOS-Installation auf Aquaris X Pro fehlgeschlagen Athene 19 2.750 24.05.2020, 22:02
Letzter Beitrag: Athene

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste