Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] ERROR 7 - Moto 1039 Peregrine
#1
Device is a MOTO 4G LTE - XT1039 / Code: Peregrine
Actual running and fine working with LOLLIPOP 5.1 - GERMAN.
-> Devive is UNLOCKED (showing hint on every (re-) start.
   (SU show/has rights)
-> TWRP 3.1.0.0 is properly installed/working
-> Developer is enabled
-> USB-debugging is enabled

PC has valid driver like "Android Device" (Motorola ADB Device).
OS is WIN-7, always up2date.
ANDROID-Tools are installed and running properly with admin-rights.
Testing connectivity:
-> adb devices        -> Show device-# ... OK !?
-> adb reboot        -> shows fastboot on phone -> OK !
-> fastboot devices    -> Show device-# ... OK !?    

Try uploading LineAgeOS (latest or any other previous available 14.1 !)
-> adb push lineage-14.1-20170511-nightly-peregrine-signed.zip /sdcard/
   ... OK ! (...1.6 MB/s (368396527 bytes in 215.391s)

Monty Python's Flying Circus would say: "....And Now for Something Completely Different !"
(very old, but well known catchphrase in europe since 1971)
 
Using TWRP with (any !) uploaded image will always end up the same:
->    Can't install this package on top of incompatible data.
    Please try another package or run a factory reset.
->    Update progress ended with ERROR: 7
    Error installing zip-file '/sdcard/lineage-14.1-20170511-nightly-peregrine-signed.zip'
   (or other)

Incompatible data ... Why this ? ? ?
Walking the WEB, i couldn't find a clue to solve this oustanding prob (not only Moto 1039).
Several people wrote: 'use EXPERIMENTAL version' to upgrade from org. stock or CWG or other...
- but where to find/load a useable file ???  

Please search forward to solve this error/bug #7.
... so many user would be appreciate having a solution or solid hints to solve the prob :-)

PS:
Oooh, Forum auf deutsch - Super !
Ich lasse den vorgetexteten Text erst mal so.

Mega-Dank für mögliche Hlfe.
Antworten
#2
Steht doch da. Factory Reset. :-)

Mach vor dem Flash ein Full Wipe. :-)
Antworten
#3
... ja, auch den Factory-Reset gemacht (wie es 'da' steht)
... ja, auch besagtes 'Fulll Wipe' (wie hier und da beschrieben)
Leider nicht geil: NoGo.

Auch alles mal platt gemacht und 'Org-Image' noch mal neu installiert ...
... und alles noch mal von vorne in div. Variationen.
Immer noch nicht geil: NoGo.

Es bleibt hier die Frage:
Wenn die LineAge-Gurus doch ein adäquates Image anbieten (für Peregrine leider nur 14.1),
dann sollte mann doch meinen/annehmen, dass das auch (irgendwann) dudelt ?
- sprich ge-checkt & getestet & lauffähig / installierbar usw.

Die andere(n) Frage(n) hier offen:
Vielerorts ist im WWW zu lesen, dass es "so" einfach von Lutscher updaten nicht funzt.
Auch nicht so mal eben schnell von einem CM-Image ....
Vom "Experimental" ist 'überall' zu lesen - nur ist hier keines für Peregrine zu finden / zu laden.
(bekanntes lineage-14.1-20170508-nightly-bacon-signed funzt logo nicht)

Ich hatte da jetzt vom Support erwartet, dass es entsprechende Images für einen
Down-to-Top schon noch irgendwo gibt.
.... oder zumindestens ein "How to", auch wenn es anstrengend & aufwendig & eher
nix für Simple-Dummies ist.
Aber halt irgendeine konkrete Info die auch zum Ziel führt ...
Antworten
#4
Rainbow 
Na geht doch :thumbsup: ... allerdings mit Mühen.
Android Version: 7.1.2, GApps mini ist auch drauf, alles scheint prima zu funzen, bisher nach ca. 4 Stunden intensiven Tests keine Anstürze oder Fehlfunktionen.

Was hab ich nun anders gemacht ?
Heute sehr früh hab ich noch ein passendes CM13 in den Abgründen meines Rechners gefunden.
Gepushed, Installationsversuch .... auch ERROR 7. Grrrr......
Reset, wipe, immer wieder: "Can't install this package on top of incompatible data"
(wo immer auch diese Meldung heraus resultiert)

Dann hab ich im TWRP noch mal richtig brutal 'ge-wiped': Alles markiert und gelöscht ! Auch SD-Karte.
Anschließend noch mal jedes Item einzeln durchgegangen und dort, wo es ging, ein "Repair" und "Resize" gemacht.
Phone bootet (logo) nicht mehr, TWRP noch da. Puuuh ...
Noch mal CM13 hochgeladen und Versuch Nr. 234: Angel ! .... Kein Gemecker, Installation läuft.

Kurz angetestet: Scheint nicht so prickelnd zu sein !? Browser schmiert immer weg, ein Absturz.
Also probieren wir doch mal, 14.1 darauf zu installieren ..... Nein, geht (auch) nicht, wie gehabt.

Das Spielchen also noch mal: Alles wie oben genannt weglöschen, Repair, Resize und gleich aufs ganze:
- Push 14.1 für die Peregrine
- Push GApps_7.1_mini
und ab die Luzi ...
 Pray Installation lief kplt. ohne Gemaule durch bis zum Reboot.
Nach ges. ca. 30 Minuten konnte ich dann meine PIN eingeben, Netzwerk einrichten, Google sein Gedöns machen lassen und div. Einstellungen vornehmen.

FAZIT:
Bin schwer begeistert Big Grin 2
Von Android 5 nach 7 ist schon ein Unterschied auf diesem vermeintlichen "Steinzeit-Handy".
Alles scheint flüssiger und sehr stabil.
Dazu hab ich noch mehr freien System-Speicher als vorher.
Ach ja: Meine Transcend-SD (32GB) wurde zwar als zu "lahm" (???) "ermittelt" - Neuformatierung klappte aber auch und Apps/Daten wurden automatisch umgelagert.

Sehr propper - saubere Arbeit !
Antworten



Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste