Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] Link2SD funktioniert nicht mehr
#1
Hallo zusammen,

ich habe bisher erfolgreich LOS 16 mit Magisk genutzt, zum Verschieben von User Apps zu System-Apps habe ich Link2SD genommen (war das Erste, was gut klappte).
Gestern habe ich wieder eine App zu einer System-App gemacht, neugestartet, LOS startete nicht mehr.

Habe nun LOS, (Gapps,) und Magisk neu installiert, habe laut Root-Checker auch Root-Rechte, allerdings kann ich mit Link2SD keine Apps mehr zu System Apps machen, ich erhalte die Meldung:

"Fehler
mount: '/system' not in /proc/mounts'

Woran kann das liegen? Hat sich da bei LOS was geändert?

Viele Grüße

Sebastian
Antworten
#2
Ist denn die Aussage "kein System in /proc/mounts" richtig?

G900F mit LOS16
Antworten
[-] Die folgenden (1) User sagen llluuuzzziii Danke für diesen Beitrag:
szoller (25.09.2019)
#3
Ja, in der /proc/mounts findet sich kein /system mount.
Laut LineageOS-IRC sei das bei manchen Geräten so normal,
ich wundere mich aber, warum das vorher funktionierte...
Antworten
#4
Eventuell gab es bei Deinem Gerät eine Umstellung hin zu "system-as-root"?
Welches Gerät und welches LOS hast Du denn?

G900F mit LOS16
Antworten
[-] Die folgenden (1) User sagen llluuuzzziii Danke für diesen Beitrag:
szoller (25.09.2019)
#5
(25.09.2019, 20:00)llluuuzzziii schrieb: Eventuell gab es bei Deinem Gerät eine Umstellung hin zu "system-as-root"?
Welches Gerät und welches LOS hast Du denn?

G900F mit LOS16

Ich habe ein Xiaomi Mi A1 und nutze LineageOS, die Nighly vom 24.09.

Wenn nun "system-as-root" ist, wie mache ich dann Apps zu System-Apps? Habe mehrere Apps versucht, die verweigern allesamt den Dienst. Manuelles einfügen der APK nach /system/app oder /system/priv-app bringt scheinbar nix, die Apps haben trotzdem keine "System-App-Rechte" Sad
Antworten
#6
In dem Thema stecke ich leider noch nicht so richtig drin. Ich gucke ersteinmal ob es diesbezüglich Änderungen gab.

G900F mit LOS16
Antworten
#7
Auf den ersten Blick ist keine entsprechende Änderung zu finden.
Allerdings ist auch fraglich ob das mit LOS zu tun hat. Wie Du selber schreibst hat es bis zu einem Neustart ja funktioniert.
Was war das für ein LOS wo es funktionierte?
Hast Du das Telefon oder die externe Speicherkarte verschlüsselt?



G900F mit LOS16
Antworten
#8
(25.09.2019, 20:42)llluuuzzziii schrieb: Auf den ersten Blick ist keine entsprechende Änderung zu finden.
Allerdings ist auch fraglich ob das mit LOS zu tun hat. Wie Du selber schreibst hat es bis zu einem Neustart ja funktioniert.
Was war das für ein LOS wo es funktionierte?
Hast Du das Telefon oder die externe Speicherkarte verschlüsselt?
Es war auch vor LOS 16, davor war das letzte Update das vom 08.08 (das Letzte vor der Updatepause), dort funktionierte das Umwandeln zu User App- LOS Update - Umwandeln zu System App noch.

Habe ich das Umwandeln zur User App vor dem Update weggelassen, war die App logischerweise weg nach dem Update. Wie gesagt, funktionierte bei jedem Update, bis zu dem vom 24.09., das war das Erste, das ich nach der Pause durchführte.

Eine externe Speicherkarte (also Micro-SD) hab ich garnicht im Einsatz.
Antworten
#9
Also ist in der Pause etwas passiert. Vom 8.8. bis 17.9. ist ein ordentlich langer Zeitraum. Das findet man nicht so nebenbei ;o(

Probiere mal zwischenzeitlich aus ob es hilft SE-Linux abzuschalten ("setenforce 0" als root im Terminal).

G900F mit LOS16
Antworten
#10
>> Probiere mal zwischenzeitlich aus ob es hilft SE-Linux abzuschalten ("setenforce 0" als root im Terminal).

Brachte leider keine Änderung Sad
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Computer findet Kalender- und Kontaktdateien nicht gogol 5 925 13.11.2019, 20:43
Letzter Beitrag: llluuuzzziii
  [DOWNLOAD] DL funtkioniert nicht membro 3 272 10.09.2019, 09:16
Letzter Beitrag: Farron
  Telefon App / Dialer funktioniert nicht richtig NonKon 4 1.668 05.09.2019, 16:26
Letzter Beitrag: NonKon
  LOS16: Gerät startet nach Update nicht mehr Syrphid 3 643 27.08.2019, 18:22
Letzter Beitrag: Syrphid
  Mobile Datennutzung wird nicht eingeschaltet LineageBubi 5 1.296 14.06.2019, 09:05
Letzter Beitrag: LineageBubi

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste