Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] i9591: Trotz addonsu nicht gerootet
#1
Hallo,
ich habe mir LineageOS 13 auf mein S4 Mini (gt-i9591) geflasht und wollte das Gerät nun für die Benutzung von AFWall rooten. Dafür habe ich von https://download.lineageos.org/extras die addonsu-armed-signed.zip über TWRP geflasht und konnte auch in den Entwickleroptionen Root einschalten. Allerdings gab es keine Superuser-App und AFWall behauptete weiter, dass das Gerät nicht gerootet sei. Auch eine SU-App aus dem F-Droid Store brachte keine Abhilfe. Root Checker sagte mir dann, das Gerät sei gar nicht gerootet.
Was kann ich tun, um das zu ändern?
Vielen Dank!
Antworten
#2
Schaut es bei dir in den E-Opts so aus?
[Bild: a87fa5594293a9804ca7c1a48468bbcf.jpg]
"Root-Zugriff" regelt ob root erlaubt ist.
"Root-Zugriffe verwalten" ist das Äquivalent zu einer SU-App, dort werden die Apps erlaubt oder verboten.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#3
Wenn nicht probiert mal chainfire Superuser zu installieren und schau ob des dann geht.

Gesendet von meinem ONEPLUS A3003 mit Tapatalk
Antworten
#4
(07.04.2017, 17:41)DarkStar schrieb: Schaut es bei dir in den E-Opts so aus?

"Root-Zugriff" regelt ob root erlaubt ist.
"Root-Zugriffe verwalten" ist das Äquivalent zu einer SU-App, dort werden die Apps erlaubt oder verboten.

Sent from my MotoG3 using CyanogenMod Forum mobile app

Ja, so sieht es aus, allerdings ist trotz Anwahl von Apps und ADB oder wahlweise nur Apps "Root-Zugriffe verwalten" ausgegraut. Würde es gerne mit Bordmitteln lösen und ungern auf Fremdapps zurückgreifen.
Antworten
#5
Schon versucht, aus den Extras von LOS, unroot und dann noch einmal root?

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#6
Also auf "deaktiviert" zu schalten und dann wieder auf "apps und adb"? Bringt leider keine Besserung Sad
Antworten
#7
Meine Erfahrung, wenn irgendwie der Wurm drin ist. Ich mache dann nicht lange rum und installiere komplett neu, einschließlich Wipe des internen Speichers und der SD Karte. Oft lief hernach alles, warum auch immer. Ist Stress pur, ich weiß, aber erfolgloses suchen ist stressiger.

LOS, SU und OpenGApps in einem rutsch installieren. GApps, wenn der Platz reicht, minimum Nano.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
[-] Die folgenden (2) User sagen DarkStar Danke für diesen Beitrag:
quaker (12.08.2019), numbi (07.04.2017)
#8
Mittlerweile konnte ich das kurz benutzen, dann war es wieder ausgegraut. Anscheinend ein Bug.
Antworten
#9
Bevor du alles neu installierst, versuch erst mal noch die addonsu-armed64-signed.zip zu flashen.
Antworten
#10
Warum arm64? Das S4 Mini hat doch keinen 64bit-Kernel? Also macht die arm64 (nicht armed64) keinen Sinn!

Vielleicht hat auch der Versuch mit der SU-App über F-Droid was kaputt gemacht. Also wenn dann alle Fremd-SU-Apps nach deren Anleitung korrekt rückgängig machen, evtl. reicht einfaches Deinstallieren nicht wenn die Root-Modifikation bleibt. Dann die "addonsu-remove-arm-signed.zip" für LOS13 flashen und booten (bzw. falls fälschlicherweise eine der falschen addonsu für arm64 oder eine der drei für LOS14.1 geflasht wurde auch die dazu passende addonsu-remove-xxx damit sicher alles weg ist) und dann nach dem Reboot nochmal die addonsu-arm-signed.zip für LOS13 flashen.

Ansonsten hilft vielleicht tatsächlich nur ein Wipe und Neuinstallation von LOS und dann eben nur die eine passende addonsu-remove-arm-signed.zip LOS13.0 nochmal.
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] A51- TWRP LÄSST SICH NICHT ÜBER odin installieren mbsauger 12 1.983 29.03.2021, 13:03
Letzter Beitrag: db91595
  LOS 16 auf einem Galaxy S5+ (SM-G901F): SIM wird nicht erkannt berndz2001 5 2.112 08.02.2021, 01:24
Letzter Beitrag: llluuuzzziii
  [LineageOS] S9+ startet (wahrscheinlich) nicht mehr Helix22 2 847 04.02.2021, 07:03
Letzter Beitrag: Helix22
  [LineageOS] LOS 17.1 auf S5neo erkennt home WiFi nicht wieder freakz80 16 5.655 26.12.2020, 22:30
Letzter Beitrag: many
  S5 SM-G900F - LOS 17.1 läuft nicht dzabler 3 2.200 17.11.2020, 18:11
Letzter Beitrag: llluuuzzziii

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste