Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] keine root rechte Galaxy S3
#1
habe das Lineage OS auf meinem S3 installiert. soweit auch alles ok.

habe nur keine root rechte, obwohl ich unter Entwickleroption unter Root Apps und ADB ausgewählt habe.

Wieso den das?
Antworten
#2
Root ist "ab Werk" bewusst nicht dabei. Musst Du separat flashen.

https://download.lineageos.org/extras

Fürs S3 ist es die ARM-Version.
Antworten
[-] Die folgenden (1) User sagen InTheY2K Danke für diesen Beitrag:
Silver-Liquid (20.05.2017)
#3
(20.05.2017, 09:21)InTheY2K schrieb: Root ist "ab Werk" bewusst nicht dabei. Musst Du separat flashen.

https://download.lineageos.org/extras

Fürs S3 ist es die ARM-Version.

hab ich auch schon versucht, nur kommt dann in TWRP eine fehlermeldung beim installieren.

Prozess Updater endete mit Meldung: 4

Fehler beim installieren von zip .........addonsu-arm-signed.zip

Das komische ist ja das es unter Entwickleroptionen auswählbar ist, dennoch keine root rechte

Edit:

habe nochmal das LineageOS drüberinstalliert in TWRP und die Gapps. Beim Supersu Addon kam aber wieder die selbe fehlermeldung.

dann nachgeschaut unter entwickleroptionen, root deaktiviert, entwickleroptionen auch deaktiviert, dann neu aktiviert und unter root apps + adb ausgewählt und dann funktionierte es
Antworten
#4
Das derzeitige offizielle SU-Paket "addonsu" hat anscheinend ein Problem und liefert auf manchen Geräten den Error 4 (auf meinem Nexus4/Mako nicht). Es gibt eine korrigierte Version, noch inoffiziell, von einer Entwicklerin als Anhang an folgenden Bugreport verfügbar gemacht: BUGBASH-246

Vermutlich wird die Korrektur irgendwann auch im offiziellen Paket landen, da wurden anscheinend nur 4 Zeilen im Update-Script gelöscht. Also wer dem inoffiziellen Paket nicht vertraut der könnte das offizielle entpacken, die 4 Zeilen löschen und wieder packen dann sollte es ohne Error 4 installieren.
Antworten
[-] Die folgenden (1) User sagen Araldo Danke für diesen Beitrag:
Jesusnagler (20.05.2017)
#5
(20.05.2017, 11:19)Araldo schrieb: Das derzeitige offizielle SU-Paket "addonsu" hat anscheinend ein Problem und liefert auf manchen Geräten den Error 4 (auf meinem Nexus4/Mako nicht). Es gibt eine korrigierte Version, noch inoffiziell, von einer Entwicklerin als Anhang an folgenden Bugreport verfügbar gemacht: BUGBASH-246

Vermutlich wird die Korrektur irgendwann auch im offiziellen Paket landen, da wurden anscheinend nur 4 Zeilen im Update-Script gelöscht. Also wer dem inoffiziellen Paket nicht vertraut der könnte das offizielle entpacken, die 4 Zeilen löschen und wieder packen dann sollte es ohne Error 4 installieren.

Irgendwie hab ich jetzt auf einmal doch wieder keine root rechte.

hab mal das unoffizielle installiert, das ging, dennoch keine root rechte, obwohl unter root apps und adb ausgewählt.

seltsam
Antworten
#6
Also ich hab das AddonSu Root im März mal ausprobiert um mit Tasker automatisch die "Mobilen Daten" ein- und auszuschalten, das geht ja nur noch mit Root. Das hat damals auf dem Nexus4 problemlos geklappt. Mehr habe ich allerdings auch nicht probiert.
Antworten
#7
(20.05.2017, 21:11)Araldo schrieb: Also ich hab das AddonSu Root im März mal ausprobiert um mit Tasker automatisch die "Mobilen Daten" ein- und auszuschalten, das geht ja nur noch mit Root. Das hat damals auf dem Nexus4 problemlos geklappt. Mehr habe ich allerdings auch nicht probiert.

oder hat es damit zu tun, weil ich nicht gleich am anfang in TWRP zu LineageOS + Gapps die AddonSu.zip ausgewählt habe um nacheinander zu installieren, bevor er überhaupt das OS startet?
Antworten
#8
Nein, nur die Gapps muß man gleich mit flashen. Ich hab damals das Root-Addon auch viel später nachträglich geflasht (inzwischen 2x Root und 2x Unroot) und mit Tasker hat es funktioniert.
Antworten
#9
(20.05.2017, 21:16)Silver-Liquid schrieb:
(20.05.2017, 21:11)Araldo schrieb: Also ich hab das AddonSu Root im März mal ausprobiert um mit Tasker automatisch die "Mobilen Daten" ein- und auszuschalten, das geht ja nur noch mit Root. Das hat damals auf dem Nexus4 problemlos geklappt. Mehr habe ich allerdings auch nicht probiert.

oder hat es damit zu tun, weil ich nicht gleich am anfang in TWRP zu LineageOS + Gapps die AddonSu.zip ausgewählt habe um nacheinander zu installieren, bevor er überhaupt das OS startet?

Nein, es hat eher damit zu tun dass du von den AddonSu.zips die 64er nehmen musst für das S3.
Das S2 und das S3 geben diese Fehlermeldungen aus die du beschrieben hast mit der einfachen Zip.
Beim S4 hab, hab ich festgestellt, funktioniert diese wiederum.

Und wenn du Root erteilst in den Einstellungen, mach danach einen Neustart, dann sollte es gehen.
Jedenfalls wars bei dem S3 das ich hatte so.
Antworten
[-] Die folgenden (1) User sagen sunneschy5 Danke für diesen Beitrag:
Silver-Liquid (21.05.2017)
#10
(20.05.2017, 23:37)sunneschy5 schrieb:
(20.05.2017, 21:16)Silver-Liquid schrieb:
(20.05.2017, 21:11)Araldo schrieb: Also ich hab das AddonSu Root im März mal ausprobiert um mit Tasker automatisch die "Mobilen Daten" ein- und auszuschalten, das geht ja nur noch mit Root. Das hat damals auf dem Nexus4 problemlos geklappt. Mehr habe ich allerdings auch nicht probiert.

oder hat es damit zu tun, weil ich nicht gleich am anfang in TWRP zu LineageOS + Gapps die AddonSu.zip ausgewählt habe um nacheinander zu installieren, bevor er überhaupt das OS startet?

Nein, es hat eher damit zu tun dass du von den AddonSu.zips die 64er nehmen musst für das S3.
Das S2 und das S3 geben diese Fehlermeldungen aus die du beschrieben hast mit der einfachen Zip.
Beim S4 hab, hab ich festgestellt, funktioniert diese wiederum.

Und wenn du Root erteilst in den Einstellungen, mach danach einen Neustart, dann sollte es gehen.
Jedenfalls wars bei dem S3 das ich hatte so.


Danke grad nochmal getestet mit der 64ger, damit ging es ohne probleme zum installieren :thumbsup:
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Samsung Galaxy S3 (GT-I9300) zu leise und Absturz des MTB Hosts Paulchen 2 309 12.11.2018, 21:28
Letzter Beitrag: llluuuzzziii
  Galaxy A3 (2017) neu aufsetzen_keine USB-Verbindung möglich zaunfink 10 664 03.11.2018, 16:12
Letzter Beitrag: zaunfink
  [LineageOS] Galaxy S5 Lineageos 15.1 Vibration Rolf-D. 0 256 31.10.2018, 13:41
Letzter Beitrag: Rolf-D.
  Speedport3 WLAN Galaxy S3 HeldImFeld 3 537 26.10.2018, 07:29
Letzter Beitrag: Struppi
  [ANDROID] Galaxy Note 4 // Triangle Away gfr 3 281 23.10.2018, 15:18
Letzter Beitrag: reset

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste