Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Signal auf Google-freien LOS-Phones - Akkuverbrauch
#1
Inzwischen bin ich bei einem Google-freien Sony Xperia XA2 mit LOS 18.1 gelandet.
Man liest öfter, dass Signal auf Google-freien LOS-Phones sehr viel Akku zieht.
Ich konnte das bisher nie bestätigen.

Jetzt aber, mit meinem Sony saugt mir Signal den Akku leer, obwohl ich diesen Messenger nur selten benutze.
Wir hatten das Thema auch schon mal hier: https://www.lineage-os-forum.de/Thread-A...-mit-LOS16
Wie kann das sein, dass das Verhalten auf verschiedenen Phones so unterschiedlich ist?

Interessant auch die Info "Verwendungsdauer" in der Anzeige der Akkunutzung:
Während die anderen Apps hier Minuten oder auch mal ein paar Stunden angeben, gibt Signal z.B. gerade jetzt 3 Tage (!) an. Das ist die gesamte Zeit seit der letzten vollständigen Aufladung, obwohl ich die App fast nicht benutzt habe.

Wie kann ich rauskriegen, was Signal da die ganze Zeit treibt?
Warum nur auf diesem Phone?
Antworten
#2
"Akku optimieren" ist für Signal eingeschaltet?
Eventuell mal über Nacht ein logcat auf dem PC mitschneiden!?
Wenn eine App "Amok läuft" sind das meist Todeskämpfe. Irgendetwas wurde abgewürgt und die App versucht krampfhaft das trotzdem zu machen. Der Klassiker sind AdAway und GoogleDienste wzB FirebaseAnalytics.
Der Fehler kann aber auch andersherum sein: die App ist tatsächlich im Hintergrund und schläft friedlich. Nur das Flag "läuft im Vordergrund" geht leider nicht ordnungsgemäß weg.

Wenn die Firmware korrekt ist hilft da wirklich nur ein logcat. Manchmal auch eine Neuinstallation.
LOS möchte bei Dir als Firmware:
"... All unpinned blobs below are extracted from H3113_Customized CE1_1312-1452_50.2.A.3.22_R1B ...."

Die pinned Blobs sind von: "... BUILD_FINGERPRINT := Sony/H3113/H3113:8.0.0/50.1.A.4.76/....."

Google Pixel 3 mit LOS18.1 + Magisk + OpenGApps
Antworten
Die folgenden (1) User sagen llluuuzzziii Danke für diesen Beitrag:
sibylla (21.06.2021)
#3

Akkuoptimierung ist (und war) eingeschaltet.

Ich habe Signal jetzt mal deinstalliert und neu installiert und neu konfiguriert.
Habe die Lesebestätigung ausgeschaltet und die Überprüfung der Kontakte bzw. Meldung von neuen Signal-Usern aus der Kontakteliste ausgeschaltet. Ich werde das jetzt mal beobachten.

Vielleicht ist es tatsächlich nur ein Anzeigeproblem, denn die letzte Akkuladung hat vier Tage gehalten. Das ist doch gar nicht schlecht. Wenn allerdings Signal davon laut Anzeige 40% verbraucht hat, obwohl ich es gar nicht benutzt habe, dann irritiert mich das schon.

Bei mir läuft Blokada als Werbeblocker. Allerdings wurde Signal in der Vorgängerinstallation an Blokada vorbeigeleitet.

Das Baseband heißt bei mir: 20191108_BY120_Daily. Ich hoffe, da muss ich nicht ran. Mobilfunk und WLan laufen einwandfrei.

Wenn sich mit der neuen Installation nix bessert, mach ich mal ein logcat und hoffe, dass ich was vom Inhalt verstehe. Confused
Antworten
#4
Ein guter Einstieg ist z.B.
https://developer.android.com/training/m...ze-standby

Wenn alles so läuft wie es soll kommt im logcat eine Meldung a la "enable doze mode". Und je nach Nutzung der Apps (häufig/nicht häufig etc.) gibts dann bei mir ca 1/h ein "WartungsZeitfenster" wo alle Apps einmal komplett durchlaufen und dann wieder tief schlummern.
Ein nacktes LOS ohne GApps mit Signal liegt so etwa bei 0,2%/h. Vollgemüllt mit GApps und viel MQTT/IOT/Tasker so etwa bei 0,8%/h. Zuerst habe ich die Problemfälle gesucht, dann IN den jeweiligen Apps an den Schrauben gedreht. Wer darauf nicht ausreichend reagiert hat durfte dann die adb-shell kennenlernen.

Nach meiner Erfahrung mag Android auch einen regelmäßigen Lebenswandel Wenn Nachts DND eingeschaltet ist und der Wecker gestellt ist, liegt das Telefon auch mal mehrere Stunden im Koma. 10 Minuten vor dem Weckerklingeln herrscht dann geschäftiges Treiben.

Google Pixel 3 mit LOS18.1 + Magisk + OpenGApps
Antworten
#5
(22.06.2021, 17:40)llluuuzzziii schrieb: https://developer.android.com/training/m...ze-standby

Danke!
Ich hab mal ein logcat studiert, da hab ich keine Einträge gesehen, die nach Todeskampf aussehen.
Die Signal-App kommt auch nicht auffallend oft vor.
Mein Phone geht auch regelmäßig in den Traumzustand über.
Mein Akku hält mehrere Tage.
Ich sag mir jetzt: das ist ein Anzeigefehler.
Damit ist das Thema für mich erledigt. Rolleyes
Antworten
#6
Sieht so aus. Besser als andersherum

Google Pixel 3 mit LOS18.1 + Magisk + OpenGApps
Antworten
#7
kurze Rückmeldung:
bei mir hat der Parameter "Einschränkung der Hintergrundnutzung" unter Akkunutzung in AppInfo den Durchbruch gebracht:
von 40% auf 3%  
https://www.kuketz-blog.de/hintergrundak...ld-teil10/

Es kann allerdings etwas länger dauern, bis eine eingehende Nachricht angezeigt wird. Das konnte ich aber noch nicht systematisch beobachten.
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Google Play APP für TracingAPP temp. auf Googlefreiem Gerät installieren? uwe75 3 3.562 04.06.2020, 12:39
Letzter Beitrag: uwe75
  [APP] Signal Messenger Hash marind 1 2.092 04.04.2020, 14:38
Letzter Beitrag: marind
  [APP] Signal Messenger mit LOS16 Gugelhupfglaubshackd 11 7.266 10.08.2019, 21:05
Letzter Beitrag: Gugelhupfglaubshackd
  Wie APKs für kostenpflichtige Apps vom Google Play Store herunterladen? Volker Wysk 13 6.011 05.03.2019, 22:22
Letzter Beitrag: Volker Wysk
  Update Google Uhr und Google Rechner funktioniert nicht hjw_vs 6 2.740 21.04.2017, 13:01
Letzter Beitrag: hjw_vs

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste