Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Sony Xperia XA2 Ultra - GAPPS lassen sich nicht flashen Errorcode 70
#1
Hallo zusammen,

nachdem ich etliche Threads und Foren durchwühlt habe und nicht wirklich weiter komme, versuche ich es nun hier. Ich weiß, zu dem Thema gibt es ein paar Threads, die aber allesamt etwas älter sind. Ich hoffe der Bereich hier im Sony Forum ist der richtige, ansonsten bitte verschieben.

Eckdaten:
Sony Xperia XA2 Ultra
256 GB Scandisk Class 10 Speicherkarte eingesetzt
Bootloader entsperrt
ADB/Fastboot inkl. passender Treiber sind auf Windows 10 PC vorhanden
Ich habe mich an die offizielle Anleitung zu dem Smartphonel gehalten
TWRP ließ sich problemlos mittels fastboot boot twrp.x.x.img booten
Lineage OS 16.0 Nightly vom 04.07.2019 ließ sich problemlos installieren
Gemäß Originalanleitung boote ich danach ins LOS-Recovery, wähle dort ADB Sideload aus und starte am PC via adb sideload gapps.xyz.zip

Und da geht das Gewurschtel los.
Benutzt hatte ich zuerst die ARM64-Android9-NANO Version. Da kam der Errorcode 64 (falsche Architektur).
Also ARM-Android9-NANO ausprobiert. Hier bricht das flashen aber mit Errorcode 70 (Insufficient storage usw., sprich: zu wenig Speicherplatz). Also ARM-Android9-PICO versucht, da wird wieder die Architektur bemängelt (bei Nano wurde ARM64 bemängelt und bei Pico ARM). Also ARM64-Android9-PICO versucht, Ergebnis Errorcode 70.

Probiert habe ich es dann nochmals via TWRP (TWRP ist gebootet u. nicht geflashed) mit dem gleichen Ergebnis.

Wie zur Hölle installiert man diese GAPPS? Bei den letzten drei Geräten hatte ich immer den größten Aufwand und Ärger mit ADB, Fastboot, Treibern, TWRP, Cyoanogenmod flashen, etc. und den geringsten mit den GAPPS und nun scheint es umgekehrt. Big Grin 2 

Also, werte Community, seht mir nach, wenn die Fragen, das Anliegen blöd oder trivial klingt und ich evtl. auch die eine oder andere wichtige Info vergessen habe. Ich hoffe ihr könnt mir helfen, indem ihr mir möglichst verständliche Infos liefert. Rolleyes

Im Endeffekt geht es mir bei den GAPPS um zwei Dinge:
1. Ich will via Playstore Apps installieren können
2. Ich will mit BusinessCalendar meine Termine mit dem Google Kalender synchronisieren können.


Zum Telefonieren, Email, etc. komme ich doch ohne GAPPS aus, oder irre ich mich da.


Vorab schonmal Danke für eure Hilfe,
Gruß Saiwaa
Antworten
#2
GApps und LOS müssen unmittelbar nacheinander geflasht werden. Erst LOS dann GApps. OHNE Neustart dazwischen!

G900F mit LOS16
Antworten
#3
Hi,
beim letzten Versuch bin ich nach dem Flashen von LOS in TWRP auf Reboot>>>Recovery, sodass ich in das LOS-Recovery gelangt bin. Ich probiere es nachher nochmal und flashe LOS neu und dann direkt danach GAPPS.

Danke für den Tipp.
Antworten
#4
So, nun hat es etwas gedauert, bis ich dazu gekommen bin, weiterzumachen.
Leider ohne Erfolg.

Wenn ich direkt nach dem Flashen von LOS via TWRP und ADB Sideload ebenfalls via TWRP/ADB Sideload die GAPPS flashen möchte, dann erhalten ich mit dem GAPPS-Pico-ARM64-xyz.zip den Errorcode 64 (falsche Architektur) und wenn ich das Ganze mit GAPPS-Pico-ARM-xyz.zip versuche, dann kommt der Errorcode 70 (insufficient storage).

Nun wollte ich die ZIP-Datei auf die SD Karte verschieben, aber die wird gar nicht am PC erkannt.

Nun habe ich also schon zwei Probleme:
1. GAPPS flashen schlägt fehl
2. SD Karte nicht erkannt


Help Exclamation
Antworten
#5
Was passiert wenn Du das ganz normal über "ZIP installieren" machst?

G900F mit LOS16
Antworten
#6
Dann kommt je nach Version (ARM64 o, ARM) der Errorcode 64 o. 70.

Ich habe es gestern noch geschafft, die GAPPS zu installieren und auch hier in dem Thread ein Posting aufzusetzen. Leider kam bei irgendeinem Mausklick die Meldung "Seite kann nicht angezeigt werden" (so oder so ähnlich) und mein Beitrag war futsch. Danach hatte ich keine Lust auf einen zweiten Versuch. Shy 

Wie ich vorgegangen bin:

Vorarbeiten:
GAPPS-PICO-ARM64.ZIP (das ist letztendlich die richtige ZIP) auf die SD-Karte in einen Ordner geschoben (ich nenne ihn mal gapps_ordner). Wahrscheinlich geht es aber auch, wenn man unten die Vorgehensweise befolgt und die GAPPS-Zip via ADB Sideload geflasht wird.
Im gleichen Ordner habe ich die Textdateit gapps_config.txt angelegt. In dieser Datei kann man entweder erfassen, welche Pakete installiert werden sollen (INCLUDE) oder welche ignoriert werden sollen (EXCLUDE). Hier habe ich eingetragen, dass das Google Dialer-Framework und Google-Text-To-Speech exkludiert werden sollen. Die Namen der Pakete findet man z.B. hier.
In meiner gapps_config.txt stand also drin:

Code:
EXCLUDE
DialerFramework
GoogleTTS
Über diese Vorgehensweise erreicht man, dass der benötigte Speicherplatz geringer ausfällt.

1. Gemäß offiziellem LOS-Installation-Tutorial habe ich via TWRP den ADB Sideload gestartet und dann via ADB Sideload die LOS-ZIP geflasht.
2. Vorsichtshalber via TWRP den Dalvik/Cache gewiped (irgendwer sagte mir mal, vor irgendwelchen Aktion den Dalvik/Cache wipen schadet nie Smile ).
3. Nun bin ich hin und habe erneut via ADB Reboot Boatloader und Fastboot Boot TWRP-x.x.x-x-xyz.img TWRP gebootet. Ohne diesen Schritt bekam ich beim Versuch via TWRP>>>INSTALL die ZIP zu flashen den Fehlercode 70.
4. *Trommelwirbel* Via TWRP>>>INSTALL von der SD-Karte im Ordner gapps_ordner die GAPPS-PICO-ARM64-xyz.ZIP ausgewählt und den Vorgang gestartet.

Voilá, die GAPPS wurden installiert.

Ich konnte danach wunderbar in LOS starten, die ersten Setups vornehmen und und und.
Da ich auch Link2SD installieren wollte und hierfür die Partitionierung der SD-Karte erforderlich ist, wollte ich TWRP als Recovery nutzen. TWRP hatte mich zwar vor dem ersten LOS-Boot gefragt, ob es installiert werden soll, was ich auch bejaht habe, aber irgendwie ließ es sich nicht mehr aufrufen (via LOS-Neustart-Menü >>> Recovery) und war auch sonst nicht auffindbar. Also habe ich mich durch diverse englischsprachige Threads durchgewurschtelt und irgendwo den Tipp entdeckt, wie man das TWRP-Image auf die Bootpartition flasht. Natürlich ausprobiert und nun komme ich bei jedem Neustart ins TWRP, aber nicht mehr ins LOS. Confused Exclamation Big Grin 2 
Falls also da wer einen Tipp hat, wie ich das ohne vollständiges Wiederholen aller Installationen hinkriege - her damit.

Ansonsten ist das die Baustelle für heute Abend.
Antworten
#7
Im Punkt 3. hast Du TWRP nicht auf das Gerät geflasht sondern nur gebootet. So wie Du Gapps geflasht hast müsstest Du TWRP auch nochmal flashen.
Die Frage im TWRP "ob die APP installiert werden soll" bezieht sich nur auf die APP! Nicht auf das TWRP-Recovery!
So wie es ausschaut, hast Du dann TWRP wirklich auf die Bootpartition geflasht ;o( da gehört das nicht hin. TWRP wird auf die Recovery-Partition geflasht.

G900F mit LOS16
Antworten
#8
Korrekt, im Punkt 3 hatte ich TWRP nur gebootet.

Flashen schlug stets fehl. Ich habe dann rausgefunden, dass es auf dem Gerät wohl keine Recovery Partition gibt, da es eine A/B Partition ist.

Kurze Frage: Lässt sich das Problem, dass ich TWRP in die Boot-Partition geflasht habe, relativ einfach beheben? Zuvor hatte ich via gebootetem TWRP ein Backup der standardmäßig angehakten Partitionen erstellt.

Danke nochmals für die bisherige und hoffentlich kommende Hilfe. :thumbsup:
Antworten
#9
Ja, Du müsstest dann noch mal ins TWRP booten und dieselbe LOS-Version flashen. Dadurch wird die Datenpartition nicht verändert und alle Deine Daten und Einstellungen müssten erhalten bleiben.

G900F mit LOS16
Antworten
[-] Die folgenden (1) User sagen llluuuzzziii Danke für diesen Beitrag:
Saiwaa (11.07.2019)
#10
So, weiter geht´s.

LOS ist geflasht.
GAPPS sind geflasht.

Nun möchte ich TWRP installieren.
Via ADB Sideload twrp.xyz.img erhalte ich die Fehlermeldung, dass es sich um keine ZIP handelt. Nun habe ich versucht eine ZIP ausfindig zu machen. Bei Github bin ich nun auf diese Dateien gestoßen und habe sie als ZIP heruntergeladen.
An anderer englischsprachiger Stelle habe ich gelesen, dass man Datein kompilieren muss. Da blick ich grad nicht durch.

Kann mir da wer weiterhelfen? Was ich benötige ist die TWRP.Zip

Und wieder Danke im Voraus Smile

/NACHTRAG: Nochmals angemerkt, das Sony Xperia XA2 Ultra verfügt nicht über die Recovery Partition. Exclamation
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  USB-Tastatur mit XA2 Ultra? osliner 0 131 15.07.2019, 13:38
Letzter Beitrag: osliner
  XA2 Ultra wird von fastboot nicht erkannt osliner 5 577 30.06.2019, 14:56
Letzter Beitrag: Saiwaa
  [LineageOS] Sony Xperia Z5 Compact erkennt Sim-Karte nicht gogol 15 1.409 01.06.2019, 18:48
Letzter Beitrag: gogol
  [LineageOS] Sony Xperia Z1C - Installation - Updates Kiesematze 0 281 26.05.2019, 19:48
Letzter Beitrag: Kiesematze
  Xperia XA2 (h4113) wird am PC nicht erkannt tomclownfisch 16 1.361 25.05.2019, 16:18
Letzter Beitrag: wowi63

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste