Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Unterstützung der AT-Kommandos
#1
Hallo zusammen,

ich wollte gerade mein Smasung Galaxy S3 mit LineageOS 14.1-20171206 Nighltly mittels MyPhoneExplorer das erste Mal mit meinem PC synchronisieren. Leider ging der Verbindungsaufbau dauernd daneben. Daher habe ich einmal in der dementsprechenden Log-Datei nachgesehen und mußte feststellen, dass das Smartphone auf das AT-Kommando
"AT+CGSN" keine Antwort schickt.

Ich habe schon alle Einstellung hinsichtlich ADB-Debugging überprüft. Da ist alles soweit ich es feststellen kann in Ordnung.

Ich gehe doch davon aus, dass die AT-Kommandos alle unterstützt werden. Aber wo liegt dann der Fehler?

Gruß
hike39
Antworten
#2
Verbindest Du über Kabel oder WLAN?

Wenn über WLAN, schau mal im Router nach, ob diese untereinander kommunizieren dürfen.

Zusätzlich muß natürlich auf dem PC und dem Phone MyPhoneExplorer bzw MyPhoneExplorer Client
installiert sein.

Gruß
Antworten
#3
(11.12.2017, 11:06)reset schrieb: Verbindest Du über Kabel oder WLAN?
Die Verbindung wird über WLAN aufgebaut. Da ich mein altes Samsung Galaxy S3 mit Android 4.3 sauber ansprechen kann, sollten die Einstellungen vom Router ok sein.
Antworten
#4
Du brauchst auf dem PC ein ModemDevice welches mit dem Handy kommuniziert. Mit AT-Kommandos sein Handy syncen ist aber auch ziemlich oldschool! ;o)



schon Konfuzius sagte "Das Ploblem sitzt immel vol dem Computel!" ;o)
Antworten
#5
@ llluuuzzziii:  Mit den AT-Kommandos wird auch nicht synchronisiert, sondern nur Gerätetyp usw. abgefragt. Damit wird sichergestellt, dass nur bekannte Smartphone unterstützt werden. Nur wenn auf eine AT-Abfrage keine Antwort erfolgt, dann geht MyPhoneExplorer davon aus, dass es mit dem angesprochenen Gerät nichts anfangen kann.
Antworten
[-] Die folgenden (1) User sagen hike39 Danke für diesen Beitrag:
mundoceleste (12.12.2017)
#6
;o) Hmm ... eventuell hat die serielle ModemSchnittstelle auf dem Handy nur einen anderen Namen als MPE das erwartet?

schon Konfuzius sagte "Das Ploblem sitzt immel vol dem Computel!" ;o)
Antworten
#7
Ich glaube ich habe den Grund für mein Problem gefunden. Nachdem ich ein Synchronisieren über USB versucht hatte, stellte ich fest, dass die USB-Einstellung "Nur laden" aktiviert war. Als ich diese auf "Transfer files" eingestellt hatte, popte auch noch ein "Privacy Guard" auf. Nach dessen dauerhaften Beruhigung konnte MPE plötzlich das Smartphone mittels AT-Kommandos erreichen.

Allerdings habe ich auch versucht von meinem Linux-PC mit Hilfe von minicom das Smartphone anzusprechen. Nur dabei konnte ich nicht herausfinden, welches Device ich hernehmen muss. Auch die Ausgabe von dmsg half bei der Suche nicht.
Dort habe ich nur gesehen, dass das Handy erkannt wird, aber nicht ein Hinweis auf /dev/ttyxyz.
Aber das ist eine andere Geschichte.

Danke für die Unterstützung. Frohe Feiertage an alle
hike39
Antworten
#8
Hättest mit lsusb oder usbview mal schauen können : https://www.systutorials.com/docs/linux/man/8-lsusb/

Gruß
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Nexus 4 Unterstützung beim flashen von LOS frozy 3 597 04.10.2018, 16:10
Letzter Beitrag: frozy
  [LineageOS] MIDI Unterstützung in LineageOS 14.1 ? HansJM 1 843 30.04.2017, 02:39
Letzter Beitrag: HansJM
  [ROM] Was wenn keine Unterstützung mehr für Gerät? Ralph63 7 1.266 30.07.2014, 23:12
Letzter Beitrag: Ralph63
  [ANDROID] Triangle-Away Unterstützung des Boeffla Kernels Technician 2 1.195 18.07.2014, 22:04
Letzter Beitrag: Technician

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste