Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Updateprobleme mit 17.1, Sony Xperia XA2 (H3113) [pioneer]
#1
Hallo Forum,

ich benutze ein Sony Xperia XA2 (H3113) [pioneer] mit LineageOS 17.1 vom 18. Juni 2020. Ich habe Work profiles über Island Space aktiviert. Zudem microG. Zeitweise hatte ich mal den Mehrbenutzerbetrieb aktiviert.

Nun wollte ich vor ein paar Wochen auf eine neuere Version updaten (inzwischen gibt es z.B. die Version vom 23. Juli). Allerdings funktioniert das nicht. Das Gerät lädt das Update runter, installiert es - alles ohne Fehlermeldung. Dann misslingt das Starten und er empfiehlt mir ein factory reset, was ich nicht machen will. Nach mehreren Neustarts und Drücken von irgendwelchen Tasten (hab da noch kein Muster erkennen können), startet er das alte System dann wieder.

Gibt es irgendwelche bekannten Probleme beim Updaten? Evtl Konstellationen, die man vermeiden sollte, oder Modifikationen am System, die ein Update behindern könnten?

Und noch eine Frage: es werden ja relativ häufig Updates vom gesamten System angeboten. Sollte man die, wenn möglich, immer einspielen? Woher weiß man, ob es sich um feature updates oder security updates handelt?

Vielen Dank und viele Grüße,
villamoore
Antworten
#2
LOS for MicroG gibts nicht als 17.1
Hast Du 16.0 installiert und dann LOS17.1 einfach drübergebügelt?
Welches Recovery hast Du?

i9505 mit LOS17.1
Antworten
#3
Ne, ich hab nicht LOS for MicroG, sondern das MicroG nachtraeglich selbst per Hand installiert. Hatte die Vorgaengerversion von 17.1 drauf. War das 16.0?

Aber: inzwischen hab ich ja schon laenger 17.1 am Laufen. Nur ich bekomm die neueren Updates von 17.1 nicht installiert. Meinst Du, microG koennte das Problem sein?
Antworten
#4
Oh je. Da habe ich keine Ahnung. Allerdings gibts ja Gründe warum "LOS for MicroG" existiert? Das nackte MicroG über nacktes LOS drüberbügeln funktioniert definitiv nicht. Im Minimum muss der Kernel umgebaut werden!

Ja, wenn MicroG und LOS ein Problem miteinander haben, kann das dazu führen, daß LOS nicht mehr starten kann/will.

i9505 mit LOS17.1
Antworten
#5
Hm, das versteh ich nicht recht. Ich hab die Pakete ueber deren repo installiert wie hier angegeben:

https://microg.org/download.html

signature spoofing funktioniert nicht (dafuer braeuchte man dann vermutlich den modifizierten Kernel), aber der Rest ... Einige Apps melden, dass sie ohne Google Play services nicht funktionieren und tun es dann aber trotzdem.
Antworten
#6
Es gibt 1mal MicroG als einzelne Pakete (für GEEIGNETE ROM's) und zusätzlich "LOS for MicroG" (weil LOS als solches NICHT geeignet ist).
Wenn signaturespoofing nicht unterstützt wird (wie z.B. bei LOS) kann MicroG nicht funktionieren. Das einige Apps trotzdem funktionieren zeigt, daß man die Google-Dienste nicht zwingend für alles braucht.

i9505 mit LOS17.1
Antworten
#7
OK.

Wenn grad nur ein paar microG-Pakete installiert sind und die sowieso nicht funktionieren, wieso sollten die den System-Update-Prozess dann so fundamental beeinflussen koennen?
Antworten
#8
"Nur ein paar ..." ist ja relativ. Der Linux-Kernel (also die oberste Instanz auf dem Telefon) wartet nicht bis die Haustür aufgebrochen ist sondern verabschiedet sich schon wenn ein Typ mit Augenbinde vor der Tür steht!
Und das ein 17.1-Kernel mit 16.0-Systemdiensten große Bauchschmerzen hat, ist klar. Wenn die dann noch den Kernel "austricksen" wollen, erst recht.
Du könntest ja mal versuchen ob das Deinstallieren der MicroG-Erweiterungen hilft!?

i9505 mit LOS17.1
Antworten
#9
Bei Dir kommt noch dazu, daß Du ein sogenanntes A/B-Device hast. Möglich wäre auch, daß es Probleme mit der Verschlüsselung gibt. Oder tausend andere Sachen, wo MicroG direkt oder indirekt beteiligt sein könnte.

i9505 mit LOS17.1
Antworten
#10
OK. Ich probier mal alles ohne microG.

Aber die Begruendung mit dem Kernel passt nicht, in meinen Augen. Die Pakete sind ja installiert und das System funktioniert. Nur halt nicht das Update (von 17.1 auf 17.1 !!) ...

Zitat:es werden ja relativ häufig Updates vom gesamten System angeboten. Sollte man die, wenn möglich, immer einspielen? Woher weiß man, ob es sich um feature updates oder security updates handelt?

Hat jemand dazu noch n Tipp?
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Lineage OS Installation Xperia 10 -> Bootloop -> Bootlock Geronimo 3 1.804 06.05.2020, 08:51
Letzter Beitrag: llluuuzzziii
  Xperia XA2 (h4113) wird am PC nicht erkannt tomclownfisch 18 5.507 02.04.2020, 07:52
Letzter Beitrag: wowi63
  [LineageOS] Sony Xperia Z1C - Installation - Updates Kiesematze 3 4.545 11.08.2019, 21:31
Letzter Beitrag: Kiesematze
  [LineageOS] Kamera hängt sich ständig auf Xperia XA2 (h4113) tomclownfisch 1 1.381 07.08.2019, 14:10
Letzter Beitrag: tomclownfisch
  Sony Xperia XA2 Ultra - GAPPS lassen sich nicht flashen Errorcode 70 Saiwaa 14 4.390 18.07.2019, 11:28
Letzter Beitrag: Saiwaa

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste