Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LOS 16.0] "Can´t load Android system ..." nach Update auf Version vom 29.7.19
#1
Eckdaten:
Sony Xperia XA2-Ultra Modell H3213
Bootloader entsperrt, Gerät gerootet, Rootzugriff mittels Magisk hergestellt, AF+Wall als Firewall aktiv, ebenso AdAware.
Nachdem LOS geflasht war, habe ich GAPPS-ARM64-PICO installiert u. via gapps-config.txt angegeben, dass das DialerFramework und GoogleTTS bei der Installation exkludiert werden.

Über die in LOS eingebaute Update-Funktion habe ich die Datei runtergeladen und installiert. Beim Neustart lande ich im LOS-Recovery mit der Meldung:
"
Can´t load Android system. Your data may continue to get this message, you may ne[...] factory data reset and erase all user da[...] device.
Try again
Factory data reset
"

[...] bedeutet, dass der text an der Stelle außerhalb des Bildschirms liegt.

Von einer Updatefunktion würde ich eigentlich erwarten, dass sie ein Update hinbekommt, ohne das OS zu zerlegen und ich nicht erneut mehrere Stunden vorm PC verbringen muss, um nochmals mein Gerät zum Laufen zu bekommen.

Hat jemand eine Idee, was ich nun tun muss?

Voraussichtlich wird dies das letzte Update sein, dass ich durchführen werde und mich lieber bis zum Ableben des Smartphone mit der ein und selben Version von LOS zufrieden geben, wenn das jedes Mal solch einen Aufwand nach sich zieht.

Danke vorab für jegliche brauchbare Hilfe.
Antworten
#2
Kurzer Zwischenstand:
Nach einem Fullwipe habe ich nochmals mittels gefastbootetem TWRP die aktuelle LOS geflasht, danach wie gehabt die GAPPS mit den beiden exkludierten Dateien. Danach kurze Einrichtung und Magisk Root Gedöns geflasht. Danach Titanium Pro installiert, von der SD Karte die Backup-Zip in den TitaniumBackup Ordner im internen Speicher entpackt, das Handy neu gestartet, damit Titanium das Backup auch findet (war zuvor nicht der Fall) und dann bei der Stapelverarbeitung ausgewählt, dass er alle Anwender- u. Systemdaten wieder herstellen soll.

Rund 20 Minuten später der große Moment ....

"Can´t load Android system. Your data may continue to get this message, you may ..."

Ich fasse mal zusammen:
Ich nutze ein Android OS, das sich mit seiner Update-Funktion selbst zerstört.
Ich nutze eine Backup-App, die mit dem Wiederherstellen eines Backups (welches von einem Zeitpunkt stammt, wo alles fast problemlos lief) das OS zerstört.

Folge: Zunehmend verliere ich das Vertrauen in LOS und in Titanium Backup.

Egal, fange ich halt wieder von vorne an.^^
Antworten
#3
Nächster Zwischenstand, vielleicht ist das von allgemeinem Interesse oder hilft anderen Leidgeplagten weiter.

Offensichtlich hat die LOS Nightly Version vom 29.07.2019 ein Problem mit meiner open_gapps-arm64-9.0-pico.ZIP
Beim Versuch diese wie gehabt in Verbindung mit der gapps_install.txt zu installieren, erhalte ich den Errorcode 64 (falsche Version/Architektur).
Nachdem ich nun die LOS Version vom 28.07.2019 geflasht habe, lässt sich die GAPPS-ZIP wieder installieren ohne rumzumeckern.

Ich bin etwas ratlos, aber nun gut, weiter geht´s ...
Antworten
#4
Probiere doch mal die Variante MIT DialerFramework!? Ich glaube nämlich nicht, daß Google das so vorgesehen hat.
Außerdem: wenn ich das richtig interpretiere geht alles bis zu dem Moment wo das Titanium-Backup zurückgespielt wird?

G900F mit LOS16
Antworten
#5
Außerdem bin ich noch nicht sicher, daß Du im "LOS-Recovery" landest.

G900F mit LOS16
Antworten
#6
Hi,
also im LOS Recovery war/bin ich gelandet. Definitiv. Die Ansicht kenne ich aus den Versuchen, wo ich gezielt dort rein bin.

Das DialerFramework hatte ich ja rausgenommen, da die Gapps-Zip anscheindend zu groß war, sodass jedes Mal der Errorcode 70 ausgeworfen wurde. Ein Versuch wäre es wert. Kann ich denn das DF problemlos wieder deinstallaieren, wenn dies keine Abhilfe bringt?

Das Problem mit o.g. Fehlermeldung nach dem Titanium Backup konnte ich nun eingrenzen. Es ist die gleiche Ursache, die gestern durch mich verursacht wurde als ich "Telefon" (com.android.phone) via SD Maid eingefroren hatte, um zu schauen, wie sich der Dialer dann verhält. Nach Abschluss der Wiederherstellung erscheint die Meldung, dass com.android.phone mehrfach beendet wurde. Der Versuch via SD Maid den Zustand der App zu prüfen konnte nicht durchgeführt werden, da das System automatisch ausgeschaltet hat und dann ins LOS Recovery ist, um mit der o.g. Fehlermeldung aufzuwarten. Wenn ich nun wüsste, wie ich das Backup starten kann ohne dass com.android.phone wiederhergestellt wird, hätte ich Hoffnung, eine Menge Arbeit zu sparen.
Antworten
#7
Soweit ich weiß können Teile von GApps nur beim Flashen hinzugefügt/entfernt werden.

Ansonsten gebe ich Dir den Tipp ersteinmal eine Standard-Installation zu versuchen ohne dabei mit einem Skalpell am Android rumzuschnipseln ;o)

G900F mit LOS16
Antworten
#8
Big Grin 2
Standard hatte ja schon gefunzt.
Nun wird mit Netz und doppeltem Boden geschaffen. Nachdem heute Nacht alles soweit aufgespielt war, dass es grundlegend funktioniert, habe ich heute morgen mit TWRP ein Backup gemacht und zwar von den einzelnen Partitionen als auch ein System-Image. Das wandert nun grad auf den Büro-PC, in meine Cloud und heute Nachmittag zusätzlich auf eine externe HDD. Nun noch ein paar Feinheiten, dann nochmal ein Backup mit Titanium und DANN, wenn alles läuft und ein weiteres Backup mit TWRP meiner fast fertigen Wunschkonstelletaion gemacht ist, DANN skalpelliere ich wieder dran rum.

So ist der Plan. Rolleyes
Antworten
#9


G900F mit LOS16
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Fingerabdruckscanner funktioniert nicht mehr nach Update tomclownfisch 5 1.025 25.10.2019, 08:43
Letzter Beitrag: daywalk3r666
  Boot/Bootloop nach App Installation/Aktualisierung molojose 2 2.210 01.03.2018, 14:44
Letzter Beitrag: molojose
  [CM] Xperia Mini st15i & CM11: Nach Standby funktioniert Touchscreen manchmal nicht dHan 10 3.359 18.10.2017, 07:39
Letzter Beitrag: dHan
  CyanogenMod Version für Galaxy A3 Duos schrodi 4 2.034 09.05.2017, 15:39
Letzter Beitrag: schrodi
  [CM] Nach Update CM11 teilweise Abruch von Apps Schneemann 7 1.764 03.11.2016, 17:00
Letzter Beitrag: Andyrandy

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste