Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LOS 19.1/27.08.22 auf pocophone (pF1), @home kein stabiles WLAN, closed, not solved
#1
LOS 19.1/27.08.22 auf pocophone (pF1), @home kein stabiles WLAN

Hallo @all,

ich bin Mitte/Ende Sept. in einer Hauruck-Aktion auf LOS 19.1 auf pF1/Xiaomi umgestiegen. Sehr erfreulich, dass man damit die absolut OK HW (mehr brauche ich wahrlich nicht) mit Android 12 weiter nutzen konnte.

Manche der alten Apps konnte ich nicht installieren, da irgendwas mit Google gebraucht wird, wie Aquamail/Sygic. Manche andere liessen sich auch installieren, doch konnten nicht gestartet werden. Ist dann halt so. Der VErlust war wahrlich nicht soooo dramatisch. Auf 19.1 funktionieren gar Banking-Apps. Wow.

Im Urlaub hatte ich in Portugal und Spanien (frisch installiert, etwas Umstellungskopfschmerz :-)) kein echtest einziges Problem, die Batterielaufzeit war sehr gut, einzig, wenn man viele Bilder machte, ging der Akku am Ende des Tages gegen 20/21:00 Uhr in die Knie und es war dann game over.
Ich hatte auch in den vielen Cafes, Hotels mit keinem WLAN ein Problem. Soweit so gut, der Umstieg war also gelungen alles(?) funktionierte, works as designed. Wow.

Als ich noch September neu geflasht hatte, funktionierten manche der LOS 19.1-VErsionen aus Sept _nicht_, Videos-/Musikdateien brachten die App onboard zum Absturz, also ging ich schritweise rueck um dann mit dem 27.08.22-Image LOS 19.1 ein stabiles Image zu installieren (-> mit diesem Image Urlaub)

Leider, warum ich auch hier schreibe, was leider eine bittere Ernuechterung ist, dass _gerade_ @home das WLAN absolut _instabil_ ist, zu keinem der APs (ein Zoo alter/nicht so alter, moderner HW) haelt der pF1 eine stabile WLAN Verbindungen. Es ist zum Weglaufen. :-( :-( :-( :-( :-(

Hingegen, s.o. (Hotels/Cafes) kann ich bei Freunden, wie bei den Eltern (FB7390) mich stabil verbinden, 2,4 o. 5,0 beides funkt/e ohne Kopfschmerzen.

@home ist *nur* eine stabile Wlan Verbindung (2,4) mit

* Debian 8.x auf AtomPC, per USB CSL-27395 (Chip RT5572) auf 2,4 (hostapd/dnsmasq, dhcp Linux-Server im LAN)
* Raspi 3, int. WLAN auf 2,4

moeglich. Den RT5572 habe ich leider nicht auf 5.0 bisher konfigurieren koennen, weil zu doof.
Der Raspi 3 kann laut Doku nur 2,4. Mit diesen beiden APs funkt der pF1 mit LOS 19.1 stabil, sehr stabil, Videostreaming v. Linux-Vdr.

Aber ...

LOS 19.1 auf pF1 funkt @home *nicht* mit:

* FB7490, FW 7.12 auf 2,4/5,0 *nicht*
    Um hier eine FW Inkompatibiltaet auszuschliessen, habe ich eine andere FB7490 (als IP Client) mit akt. FW angeschlossen
    => 2,4/5,0 *nicht*

* FB 7050, 2,4 *nicht*
* FB 7330, 2,4 *nicht*
* FB 7170, 2,4 *nicht*
* Linksys WRT54GL, 2,4 *nicht*

Mag ja sein, dass dieser Zoo nicht der letzte Schrei ist, jedoch auch ein

* GWN7630, 2,4/5,0 *nicht*
funkt auch __nicht__ mit pF1 LOS 19.1.

Die GWN7630 setze ich auch in produktiven LANs ein, absolut stabil und performant, VLAN, NULL Kopfschmerz etc. Aber auch mit diesen modernen Geraeten ist _kein_ stabiler Betrieb mit LOS 19.1/pF1 moeglich.

@home sind andere HW vorhanden:
* XIAOMI Redmi 6 (irgendwas) - stabil zu allen, auch als Radiusclient ueber einen der WRT54GL
* Tablet bq mit Android 6, nur 2,4, - stabil zu allen, auch als Radiusclient ueber einen der WRT54GL
* HP NB 2760 mit 2.4/5.0 - stabil zu allen o.a. APs.

Der naechste Satz wuerde der Logik nach als Fehelrquelle auf LOS 19.1 zeigen, denn der pF1 (Android 10) hatte vorher in _genau_ (ohne GWN7630) dieser Umgebung einwandfrei (2.4/5.0) funktioniert; sehr stabil zu FBoxen, als auch zu den WRT54GL APs.
Einzig, mit LOS 19.1 hatte ich im ganzen Urlaub nie WLAN Probleme, s.o. auch bei Freunden und/oder Eltern (FB 7390) funkt LOS 19.1 akt. einwandfrei.

Faktisch habe ich hier @home nur zwei APs, den Raspi 3 und den AtomPC mit USB-Chip RT5572, alle anderen sind max. instabil.

Habe auch versucht die Kanaele voneinander zu trennen, dass nicht alles z.B. auf Ch5 liegt, keine Abhilfe (hatte ja auch vorher funktioniert), ebenso das Bandsteering ein-/auszuschalten hat nichts gebracht.
Eine Neuconfig der WLAN-ZUgaenge (zum x-ten Mal, der QR Code macht es doch sehr angenehm) brachte auch keine Verbesserung. Egal, was ich irgendwo an/abklickte (egal auf welchem AP) brachte fuer LOS19.1/pF1 eine Verbesserung.

Die Symptomatik ist, dass LOS 19.1 sich verbindet, oft aber, z.B. wenn ich FFox/Email aufrufe sofort das WLAN Symbol rechts oben weg geht, ... Du bist offline. :-(

Ich habe auch versucht, wie im Cafe *nur* eine einzige Zelle zu konfigurieren, GWN7630, damit LSO 19.1 nicht rumspringt, auch das fuehrte zu keinem stabilen Betrieb. Ebenso _alle_ Zellen ABzuschalten => :-(

Unter Netzwerkdetails faellt LOS 19.1 zwischen Verbunden/Nicht verbunden hin und her. Auch die MAC-Adresse nicht zufaellig (Ausverkauf der IP-Adressen auf dem dhcpd) auszuwaehlen, sondern die MAC der HW zu verwenden brachte fuer keinen AP eine Verbesserung.

Es ist zum Verr..., zum Weglaufen, _alles_ funkt, Batt. haelt lange, einfach gut, doch @home nur kastriertes (schwaches) WLAN moeglich, sonst geht nix. Staendig ueber wg/Openvpn ueber LTE ins @home-LAN sich zu verbinden ist auch nur doof.

Hat jemand eine Idee, auch wie ich an eine Logdatei komme, die mehr sagt als Verbunden/Nicht verbunden.
Sollten Daten, Angaben fuer eine Hilfestellung fehlen, bitte ich Nachfrage, gerne liefere ich diese nach.

Danke vorab @all
Gruss
ELindemann
Antworten
#2
Sorry - nicht böse gemeint.
Du schreibst viel.
Aber um irgend etwas nachvollziehen zu können
- WO ist das LOS her (Link)
Antworten
#3
Hallo db91595,

(28.11.2022, 14:50)db91595 schrieb: Sorry - nicht böse gemeint.
Du schreibst viel.
Aber um irgend etwas nachvollziehen zu können
- WO ist das LOS her (Link)

nee, passt schon. Ich koennte natuerlich schreiben, Wlan funkt mit keiner AP-Zelle @home. 
Da liefere ich schon mal alles mit, WAS ich bisher probiert habe, was alles hier rumfleucht und in Betrieb ist. Es ist eben alles, was ich bisher unternommen habe, das Problem selbst zu loesen, nix davon fruchtete.

Ich hatte das Image, die ZIp-Datei von hier
<https://download.lineageos.org/beryllium>
da sind jetzt nur noch Images v. Nov. 2022.

Das Image, was ich auf dem pF! habe ist dieses:
md5sum lineage-19.1-20220827-nightly-beryllium-signed.zip
=>
b9390f59de39ada07f989d179f97c3c1 *lineage-19.1-20220827-nightly-beryllium-signed.zip

Ich habe mir die Recent Changes angeschaut, nur 3x WLAN. Ich denke so einen Bock, so eine massive Instabilitaet haben die Entwickler ___sicher____ nicht uebersehen, bin -wie es ausschaut- allein auf weiter Flur.

<https://mega.nz/file/1pVEWC5C#KfO0f5S5b8Gp9d2Z6Zno0rKKtTOxvgQvxEjQ9iZY47Y>

Obwohl ich LOS gigantisch finde, vermisse gar nix, (fast) alles funkt, kann ich @home das Ding nicht benutzen, sprich die Tage gehe ich auf xyz-CustomRom (oder gar zu MUIU :-(  :-( :-( )

Weisst Du wie ich ein update/upgrade machen kann, OHNE alle Apps und Daten platt zumachen, denn so ist dieses ROM _leider_ nix fuer mich, also die Flucht nach vorn, update/upgrade von akt. nightly builds.

Noch eine Frage, linux an sich ist je nach Config doch seeehr gespraechig, wo/wie kann ich mehr lesen, warum
* der Internetzuagng nicht OK sei
und/oder
* der pFQ staendig aus den APs rausspringt.
Irgendwie muss doch das alles in einer Log ankommen?

__Danke__, dass Du Dir die Muehe gemacht hast.

Gruss
ELindemann
Antworten
#4
Konnte mit

adb logcat -db radio > radio.txt
und
adb logcat -d > logcat.txt

Logdateien auf dem PC einfangen. Doch, ob hierin WLAN INfos sind? :-|

Gruss
ELindemann
Antworten
#5
o.k. das LOS ist von der offiziellen Seite.
Falls du die Entwickler ansprechen willst: schau mal auf LOS HomePage ob du da eine Kontaktmöglichkeit zwecks Fehlermeldung findest.
Das hier ist ein privates Forum (was direkt mit LOS nichts zu tun hat).

Update: innerhalb einer Android-Version kann man mit "dirty-flash" direkt über ein laufendes LOS ein Update darüber installieren (Hanbbetrieb).
Da gibt es kein "Format Data". Nur bei einem Upgrad (von einer Android-Version zur nächsten) muss man die Install-Anleitung lesen.

Was kann Probleme bereiten: Update downloaden und NICHT mit "sha256sum" überprüfen. Vertrauen ist hier nicht gut - überprüfen immer.
Recovery - kann mit TWRP funktionieren. Funktioniert SICHER mit LineageRecovery.

"linux an sich ist je nach Config doch seeehr gespraechig"
Android läuft auf Linux-Basis - ist nur bedingt vergleichbar da Android stark angepasst ist. Das, was AOSP nicht drin haben will - haben die "raus operiert".
Antworten
#6
Hallo db91595,

(28.11.2022, 18:51)db91595 schrieb: Update: innerhalb einer Android-Version kann man mit "dirty-flash" direkt über ein laufendes LOS ein Update darüber installieren (Hanbbetrieb).
Da gibt es kein "Format Data". Nur bei einem Upgrad (von einer Android-Version zur nächsten) muss man die Install-Anleitung lesen.

Was kann Probleme bereiten: Update downloaden und NICHT mit "sha256sum" überprüfen. Vertrauen ist hier nicht gut - überprüfen immer.
Recovery - kann mit TWRP funktionieren. Funktioniert SICHER mit LineageRecovery.

@Hashsummen, Du hast Recht, wozu hat man diese. :-)

Danke nochmals fuer deine Hilfe.
Sollte ich mal Erfolg haben, dann gibt es hier irgendwann eine Rueckmeldung. Noch eine INfo @Thematik, gestern Abend hat ein Freund mit HW Google Pixel3 (irgendwas) und Android 12 das __selbe__ Problem, dass er  mit den o.a. APs keine stabile Verbindung aufbauen konnte. Andere HW, anderes  ROM. Also brauche ich schonmal gar nicht das Pixel Expr. CustomRom. :-)

Danke.
ELindemann
Antworten
#7
Also wenn es nicht an deinem Telefon liegt, dann kann es doch eigentlich nur an deiner WLAN Infrastruktur liegen. Wenn Du Lust hast, sichere deine derzeitigen Einstellungen und setz den Router einfach mal zurück und lass ihn anschließend auf Standard Einstellungen fürs WLAN. Nur das 2,4/5 GHZ WLAN trenne ich grundsätzlich auf, gleich im Namen die GHZ verewigen, dann hat man kein Problem mit ständigen Wechseln. Gibt es irgendwelche Exoten in der nahen Umebung die dazwischen funken können?
Antworten
#8
Hallo WST61,

(29.11.2022, 21:19)WST61 schrieb: Also wenn es nicht an deinem Telefon liegt,

das ist z.Z. nicht so klar. Wie ich vorher schrieb, mit XiaomiROM (Android 10) hatte ich diese Problem *nicht*. Mit LOS 19.1 auch nur hier, nicht draussen.

(29.11.2022, 21:19)WST61 schrieb: dann kann es doch eigentlich nur an deiner WLAN Infrastruktur liegen.

Nee, das denke ich nicht, denn ich habe alles ausprobiert, ausserdem s.o. und ein anderes Xiaomi mit Org-ROM hat dieses Problem *nicht*. Ein Freund mit Apple-Tel. (nie meine Welt gewesen) auch nicht.
Ausserdem habe ich die Ch.-Verteilung variert. Nix gebracht.

(29.11.2022, 21:19)WST61 schrieb: Wenn Du Lust hast, sichere deine derzeitigen Einstellungen und setz den Router einfach mal zurück und lass ihn anschließend auf Standard Einstellungen fürs WLAN.

Habe ich auch schon gemacht, die FB7490/DSL das WLan abgeschaltet, eine frische :-) 7490 als IP Client mit s.u. gemeinsamen Namen fuer 2,4/5.0, als __auch___ getrenntem Namen, nix gebracht.

(29.11.2022, 21:19)WST61 schrieb: Nur das 2,4/5 GHZ WLAN trenne ich grundsätzlich auf, gleich im Namen die GHZ verewigen, dann hat man kein Problem mit ständigen Wechseln.
Der GWN7630 (tolles Geraet, echt cool, fuer wenig Geld) war auch so eingreichtet, mal gemeinsam, mal getrennt => nix stabil, nix gebracht, MAXIMALER Frust, war die letzte Karte mit HW spielen zu koennen, wer braucht eine FBox, wenn ich VLAN-WLAN damit betreiben kann, zudem als Wolke im Haus, mit zwei Klicks eingerichtet.

(29.11.2022, 21:19)WST61 schrieb: Gibt es irgendwelche Exoten in der nahen Umebung die dazwischen funken können?

Das ist es auch, was ich vermute.
Und _doch_ zeigt es auch LOS, ohne dass ich LOS schlecht reden will, ich bin begeistert (sic), das, _was_ ich immer suchte, alles :-), naja fast alles funkt, frisst wenig Batterie, _stabil_ (mal das WLan nicht betrachtet, aber auch nur @home), __was__ will ich mehr, zudem man neue Android-Versionen kriegt. Cooooool.

Es ist auch der __immense__ FRUST, dass ich dieses tolle System _wahrscheinlich_ v. pF! runterschmeissen, rueckgehen muss auf diese bunte (nicht sooo schlechte), aber doch versuchte GUI namens MUIU, zudem noch Google wieder onboard ist.

@Exoten
Es gibt einen Neubau eines KH in der Naehe, sagen wir mal 50/70 m max. Haben paar :-) Antennen auf dem Dach. Es ____kann____ sein, dass sie so maechtig strahlen, dass @home diese Be-Strahlung genaue dieses Verhalten hervorruft. Wenn das so waere, habe ich ehe die A-Karte, dagegen werde ich (geschweige ich kann es ja nicht mal nachweisen, alles spekulativ) nix machen koennen. Das Haus verkaufen? :-) ;-)

Doch, warum funkt(e) das _alte_ XiaomiROM (Android10) einwandfrei?
Ausserdem, warum kann ich zu dem USB-WLAN am Linux/Debian eine _sehr_stabile Verbindung aufbauen?
Ebenso, wen ich in der Nahe bin, zum int. WLAN des Raspi.
Beide auf 2.4, nix 5.0.
Auch, wenn ich genau diese Frequenz/Channel auf den FBoxen und auch auf dem GWN einstellen, es funkt trotzdem nicht. Ahhhhhhhhhhhh Undecided

Ich habe halt keinen logischen Ansatz, warum/wieso. Die Logdateien zeigen nicht unbedingt, dass das WLAN OK, nicht OK ist. Da komme ich auch nicht weiter.

Einzig (sichern mit TWRP, wie muss ich nochmal schauen), platt machen, und andere ROMs ausprobieren, evtl. Android11/LOS 17(?) oder halt XiaomiROM. Wenn platt, kann ich dann viel probieren (mein Fehler damals), und sogleich das WLAN probieren. Wenn stabil, ist gut, wenn nicht, next CustomROM.

War halt ein Versuch bei LOS 19.1 zu bleiben, nicht alles nochmal von Null aufzubauen. halt dg, sieht verdammt danach aus.

Eine Idee ist mir noch so ein billig Xiaomi (techTage Bewertung, Redmi 10/11 oder sowas) zu holen und gleich platt zu machen, ohne den pF1 anzufassen.

Danke Dir.
ELindemann
Antworten
#9
@WST61

TWRP Backup ist ja doch beherrschbar.

Gruss
ELindemann
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Mediendateien gehen nicht - kein Ton - Videos ruckeln MrMojoRisin666 17 9.115 31.01.2023, 01:11
Letzter Beitrag: pogpu
  [LineageOS] kein GPS mit OsmAnd ohne Gapps (Lösung) Dornenteufel 1 1.210 09.09.2022, 20:23
Letzter Beitrag: WST61
  LOS 19.1 nightly 20220802 WLAN unavailable / rollback to previous build karrer 2 1.131 03.08.2022, 20:59
Letzter Beitrag: db91595
  [ANDROID] Kein WLAN nach Kanalwechsel ms.fox 5 2.388 15.03.2022, 12:27
Letzter Beitrag: etron770
  WLAN Symbol dauerhaft in oberster Leiste sichtbar machen unter LOS18.x uwe75 7 2.569 29.10.2021, 18:16
Letzter Beitrag: wowi63

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste