Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] LineageOS 14.1.x neu auf Galaxy S-2 - Fragen
#1
Hallo!
Ich hab es geschafft, endlich von Android 4.0.3 auf das neueste LineageOS upzugraden. In der Anleitung, der ich gefolgt bin (allerdings über Ubuntu, mit Windows ging es nicht wg. USB-Problemen) https://mathag.jimdo.com/2017/01/22/line...n-heimdall
wurde empfohlen, die zusätzliche 32GB-SD-Karte zu formatieren. Dies habe ich vergessen, sonst aber alle Vorgänge erfolgreich durchgeführt.

Das S-2 läuft einwandfrei und ich habe vollen Zugriff auf die ext. SD-Karte. Aber ich habe keinen Zugriff mehr via USB vom PC aus auf den internen Speicher oder die zusätzliche SD-Karte. Ich weiß aber nicht, ob ein Zusammenhang zu der nicht durchgeführten SD-Kartenformatierung besteht.

Ich fand im Dateimanager des LineageOS eine Möglichkeit, die Formatierung unter „Speichereinstellungen” nachträglich vorzunehmen. Dabei habe ich die Auswahl, die Karte entweder „einfach so” zu formatieren oder aber „als intern formatieren”. Im zweiten Fall kann die Karte wohl nicht mehr ohne Weiteres von anderen Geräten angesprochen werden.

Aus dieser Schilderung ergeben sich folgende drei Fragen:
1.) Soll ich die SD-Karte überhaupt neu formatieren, oder doch so belassen wie sie ist?

2.) Wenn ich die SD-Karte neu formatiere, welche Formatierungsart ist dann vorteilhafter?

3.) Was muss ich tun, damit ich wieder vom PC aus auf die beiden Speicher des Smartphones als Massenspeicher zugreifen kann, z.B. über den Linux-Dateimanager oder über den Windows-Explorer, so wie bisher?
Antworten
#2
(16.06.2017, 23:32)Confuserix schrieb: Aus dieser Schilderung ergeben sich folgende drei Fragen:
1.) Soll ich die SD-Karte überhaupt neu formatieren, oder doch so belassen wie sie ist?
Ich würde sie mal so belassen...
(16.06.2017, 23:32)Confuserix schrieb: 2.) Wenn ich die SD-Karte neu formatiere, welche Formatierungsart ist dann vorteilhafter?
Je nachdem was für dich nützlicher ist. Ich habe lieber eine externe.....
(16.06.2017, 23:32)Confuserix schrieb: 3.) Was muss ich tun, damit ich wieder vom PC aus auf die beiden Speicher des Smartphones als Massenspeicher zugreifen kann, z.B. über den Linux-Dateimanager oder über den Windows-Explorer, so wie bisher?
Hast du die Entwickleroption freigeschaltet??
Wenn nicht dann mach folgendes:

Einstellungen -> Über das Telefon -> 10 x auf Build-Nummer tippen -> zurück in die Einstellungen -> Entwickleroptionen
dort findest du dies : USB-Konfiguration auswählen
Wähle die Einstellung MTP oder PTP, dann solltest du über Explorer zugriff auf dein S2 haben
Antworten
[-] Die folgenden (1) User sagen sunneschy5 Danke für diesen Beitrag:
Confuserix (17.06.2017)
#3
(16.06.2017, 23:48)sunneschy5 schrieb: [quote='Confuserix' pid='71949' dateline='1497648727']
[/uote]

Hast du die Entwickleroption freigeschaltet??
Wenn nicht dann mach folgendes:

Einstellungen -> Über das Telefon -> 10 x auf Build-Nummer tippen -> zurück in die Einstellungen -> Entwickleroptionen
dort findest du dies : USB-Konfiguration auswählen
Wähle die Einstellung MTP oder PTP, dann solltest du über Explorer zugriff auf dein S2 haben

Danke für deine Tipps!
Hab die Entwickleroptionen frei geschaltet. 7 mal tippen reicht aus. Rolleyes

Wähle ich MTP für den USB-Anschluss, so wird das Smartphone unter Win 7 gar nicht erkannt.
Wähle ich PTP, so wird  es erkannt, aber ich kann nur den Gerätespeicher im Explorer sehen und in diesem werden nur zwei Verzeichnisse und deren Inhalte angezeigt: DCIM und Pictures.

Betr. USB-Einstellungen sind in den Entwickleroptionen die „USB-Debugging-Autorisierungen” aktiviert.
Ferner ist die Android Debug Bridge ADB-Schnittstelle nicht aktiviert.

Sind diese beiden Einstellungen so OK?
Und wieso wird die zusätzliche SD-Karte nicht angezeigt?
Antworten
#4
Hallo!
Das Problem habe ich jetzt ebenfalls lösen können, indem ich auf meinem PC die adb-Schnittstelle installiert habe und dabei das Galaxy nicht nur in den USB-Debug-Mode geschaltet, sondern auch die adb-Schnittstelle aktiviert habe. Den darauf folgenden Verbindungsversuch vom PC aus nahm das Smartphone erst dann an, nachdem ich die Anfrage des PC dort in einer kleinen Dialogbox bestätigt / autorisiert hatte.
Anschließend waren die Speicher immer noch nicht in Windows zu sehen. Erst musste ich den PC neu booten. Danach gelang es auf Anhieb. Den USB-Anschluss musste ich dazu in den PTP-Modus schalten.

Hilfreich waren mir folgende Beiträge aus dem Web:
http://adbdriver.com/documentation/how-t...0-x64.html
https://www.androidpit.de/adb-treiber-android-windows
http://apkinstaller.com/

Ich schreib das, weil es evtl. anderen Usern in ähnlicher Situation helfen könnte.

(Nun hab ich noch ein Problem mit "root", das ich in einem neuen Thread anfrage.)
Antworten
#5
Die Installation der ADB-Schnittstelle hat nur von 12 bis Mittag gehalten!

Nach einem Neustart des PC am nächsten Tag sowie mehreren Neustarts des Smartphones, weil ich Root installiert habe, konnte der PC das Smartphone nicht mehr über die USB-Schnittstelle finden. Statt dessen begann Windows automatisch „die nötigen Gerätetreiber zu installieren”. Vermutlich also die üblichen Samsung USB-Treiber.

Nachdem diese Treiber installiert waren, habe ich den Zustand, dass weiterhin die SD-Karten im Windows-Explorer nicht angezeigt werden. Aber beim Verbinden des Smartphones ertönt der Anmeldeton für ein USB-Gerät.

Im Gerätemanager wird SAMSUNG Android Phone angezeigt und darunter „Android Composite ADB Interface” Auf Rechtsklick / Eigenschaften wird gemeldet, dass das Gerät einwandfrei funktioniert.

Unter USB-Controller ist das Smartphone nicht zu finden. Es gibt aber einige USB-Verbundgeräte, bei denen ich nicht weiß, ob sich hinter dieser Bezeichnung doch das Smartphone versteckt.

Bei F-Droid fand ich eine App (USB-Mountr), mit der angeblich der auch in aktuellen Android-ROM enthaltene, aber nicht aktivierte USB-Massenspeichermodus aktiviert werden kann. Dann sollte das Smartphone über die USB-Schnittstelle wie bisher als Massenspeicher genutzt und angesprochen werden können.

Beim Einschalten dieser Funktion in dieser App wurde darauf hingewiesen, dass evtl. die ROM-Software die Aktivierung des Massenspeichermodus sofort wieder überschreibt.
Ich beobachtete, dass die App den gewünschten Massenspeichermodus nicht bereit stellen konnte. Ferner produzierte Windows jedes Mal das Abmeldesignal eines USB-Geräts, sobald ich einen der beiden Buttons in der App betätigte (Mount oder Unmount).

Nun weiß ich echt nicht mehr weiter! Und beim XDA-Develeoper-Forum fand ich bisher nichts dazu.
Antworten
#6
Ferndiagnose ist immer schwer.

Hast du "Verschlimmbesserungstools", CCleaner etc., am laufen? Die schaden meist mehr als sie nützen.

Verschiedene Datenkabel getestet? Samsung ist mit unter etwas eigen was seine Hardware betrifft.

Anderer PC bzw Betriebssystem getestet? Ziehe dir auf:
https://wiki.ubuntuusers.de/Downloads/Xenial_Xerus/
ein Image und boote damit den PC. Wenn dein Droide unter Linux ansprechbar ist liegt es definitiv an Windows.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#7
Hi!
Ich verwende weder CC-Cleaner noch TuneUpUtilities oder andere schlimme Dinge. Bisher hatte ich in Verbindung mit meinem alten Android 4.0.3 und den Original-Samsung-USB-Treibern keine Probleme gehabt und konnte im Massenspeichermodus auf beide Speicher voll zugrefen.
Erst durch das Upgrade auf Nougat 7.x = LineageOS 14.1 entstand das Probleem, da ja bekanntlich der Massenspeichermodus deaktiviert wurde, obwohl er anscheinend im Kernel bzw. ROM noch vorhanden ist.

Bisher habe ich konsequent zwei Möglichkeiten ausprobiert, um das Problem zu beheben:
1.) Installation der ADB-Schnittstelle.
2.) Versuch mit der App USB-Mountr.
Beides schlug fehl.


Das Flashen und Installieren von LineageOS funtionierte nur unter Ubuntu. Heimdall lieferte unter Windows immer den LibUSB-Fehler -12.

Mein Problem mit dem Massenspeichermodus lässt sich nicht dadurch lösen, dass ich auf Ubuntu umsteige. Das würde ich, wenn ich die Zeit dazu hätte, sofort gern tun. Aber solange der Umstieg noch nicht erfolgen konnte, muss ich mindestens mit Windows 7 Zugriff auf die Kamerabilder haben. (Ich benutze das Smartphone in meiner Psychotherapiepraxis und bin dort auf die Nutzung eines Windows Laptop angewiesen, weil dort das Diktierprogramm Dragon Natural Speaking drauf läuft.)

Soeben habe ich das Smartphone mit LineageOS zum ersten Mal am Laptop angesteckt, auf dem ich bisher nur mit den Samsung-USB-Treibern im Massenspeichermodus arbeiten konnte. Das Smartphone wird überhaupt nicht erkannt. Windows meldet, dass es Android-Treibersoftware installieren möchte, bricht dann aber mit der Meldung ab, dass kein geeigneter Treiber gefunden werden konnte.

Bin leider nach wie vor ratlos....
Antworten
#8
Hallöchen zusammen, wenn es dir nur darum geht Fotos usw. auf deinem Laptop zu kopieren dann Versuch es doch einfach mal über Bluetooth, oder Du lädst dir Share it auf deinem Handy und Rechner.
Das löst zwar nicht das Problem aber deine Bilder müsstest Du vorerst so kopiert kriegen.
Antworten
[-] Die folgenden (1) User sagen McNature Danke für diesen Beitrag:
Confuserix (21.06.2017)
#9
Von Umstieg auf Ubuntu war nicht die Rede. Mir ging es nur darum ob das Gerät prinzipiell ansprechbar ist. Wink

Beherrscht dein Droide USB-OTG? Mit einem Adapter und USB Stick wäre dann eine weitere Möglichkeit die Bilder zu übertragen, zusätzlich zu McNatures Vorschlag. Auch mit dem Solid Explorer könntest du per WLAN Dateien auf den PC übertragen.

So wie ich das herauslese liegt das Problem an Windows, bzw den verwenden Treibern. Würde es an deinem Smartphone liegen, hätte auch unter Ubuntu nichts funktioniert.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
[-] Die folgenden (1) User sagen DarkStar Danke für diesen Beitrag:
Confuserix (21.06.2017)
#10
Ich habe alles nochmals durchgelesen und gesehen, dass wenn du nach deiner Anleitung Lineage OS geflasht hast, du eine Unofficial-Version drauf hast.
Mein Rat an dich: mach das ganze nochmal nach dieser Anleitung: https://forstner-mcr.de/how-to-lineageos...tallieren/

Ich habe jedenfalls keine Probleme dieser Art mit meinem S2, das die Nigthly-Version drauf hat.
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Bitte Hilfe! SIM-Sperre entfernen trotz LineageOS Gortnzauntia 12 712 09.11.2018, 23:04
Letzter Beitrag: McNature
  LineageOS für Acer Liquid Zest Plus T08/Z628 BigFatAL 0 386 01.11.2018, 19:12
Letzter Beitrag: BigFatAL
  [LineageOS] Always on Display mit Galaxy S7 marksule 0 239 25.10.2018, 17:04
Letzter Beitrag: marksule
  LineageOS 15.1 - Play Store - Zertifizierung lukass2000 1 821 16.10.2018, 11:55
Letzter Beitrag: reset
  LineageOS 15.1 auf OnePlus 5T - APK aus unbekannter Quelle cosmicyes 10 2.447 15.10.2018, 10:36
Letzter Beitrag: manolitos

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste