Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Installationsprobleme beim A5 (SM-A520F)
#1
Hallo,

ich hoffe, ihr könnt mir weiterhelfen. Meine letzte Custom-ROM Installation liegt schon ein paar Jahre zurück.
Aktuell möchte ich auf einem neuen Galaxy A5 (SM-A520F) mit Stock-ROM ein LineageOS installieren. Leider funktioniert das nicht wirklich, weil die Informationen, die man im Netz bekommt, unvollständig, veraltet oder gar falsch sind. Zum anderen machen es die Hersteller einem unnötig schwer. Aber von Anfang an:

Mein erster Versuch endete in einem Gerät, das nur noch eine Fehlermeldung anzeigte und sich nicht mehr ausschalten ließ. Ich hatte mich an den Guide im Wiki von Lineageos.org zum Installieren von LOS für mein Gerät gehalten und als erstes adb und heimdall installiert. Als nächstes habe ich TWRP (twrp-3.1.1-0-a5y17lte) versucht zu installieren, allerdings ist der Guide im Wiki an dieser Stelle ungenau. Jedenfalls kam ich ein- zweimal ins Recovery, konnte aber kein ROM installieren. Nach einem Reboot wurde mir nur noch die FRP-Lock Meldung angezeigt. Ein Starten des Systems war nicht mehr möglich, nur noch der Download-Modus. Nach einiger Recherche im Netz (mit oft widersprüchlichen Ratschlägen), entschied ich mich für ein Flashen der Stock-ROM mit Odin. Der Flashvorgang brach allerdings mit einem FAIL ab. Danach erschien auf dem Gerät die Fehlermeldung, dass mit dem Firmware-Update etwas nicht in Ordnung sei und man bitte Smart Switch von Samsung ausführen solle. Das Gerät ließ sich auch in keinster Weise ausschalten. Also habe ich Windows angeworfen, Smart Switch installiert und musste feststellen, dass das Gerät nicht erkannt wurde. Als nächstes habe ich es mit KIES3 versucht, auch dort wurde das Gerät in der Notfallaktualisierung nicht erkannt. Ich konnte aber unter einem anderen Menüpunkt immerhin Modell und Seriennummer eingeben, nur um dann die Meldung zu bekommen, dass das Gerät keine Initialisierung unterstützt. Letztendlich habe ich dann nochmal den Befehl heimdall print-pit ausgeführt und plötzlich lief wieder alles, selbst alle Daten waren noch da.

Mein zweiter Versuch lief nicht viel besser ab. Ich hielt mich jetzt sklavisch an die Anleitung im LineageOS-Wiki und hatte im Gerät jetzt noch den Entwickler-Modus freigeschaltet, die OEM-Sperre deaktiviert und USB-Debugging eingeschaltet (hatte ich beim ersten Versuch versäumt). Das Installieren von TWRP lief dann auch erstmal, wobei ich der Meinung bin, dass beim Booten (oder beim Starten ins Recovery, ich weiß nicht mehr so ganz genau) ganz kurz eine winzige rote Meldung oben links angezeigt wurde. Vermutlich wieder dieser FRP-Lock. Im Recovery konnte ich keine Flash-Datei auswählen, alle Verzeichnisse waren leer. Auch das Löschen der Partitionen funktionierte nicht. Es kamen jede Menge rote Meldungen mit dem Hinweis Partitionen können nicht eingehängt werden und am Schluss Wipe failed. Danach hing das Gerät im Boot-Loop und ließ sich wieder nicht ausschalten. Einzig der Befehl Power-Off im Recovery, der nach einem Wipe erscheint (und nur der!) schaltet das Gerät aus.

So, das ist der aktuelle Stand. Ich hoffe, ihr könnt mir helfen doch noch ein LineageOS auf mein Phone zu bekommen.

Gruß Toloram


PS.: Es wäre schön, man könnte irgendwo im Netz an zentraler Stelle detaillierte Informationen und Hintergrundwissen zu dieser Thematik finden. Ich habe bei den ganzen Anleitungen und Tipps immer das Gefühl, als würde ich mit verbundenen Augen Auto fahren und neben mir sitzt jemand, der mir sagt ob ich links oder rechts fahren, Gas geben oder bremsen soll. Es wird nicht das nötige Hintergrundwissen vermittelt, weshalb ich dieses oder jenes Programm benutzen soll, wozu diese Programme nötig sind, welche Einstellungen was bewirken, wieso das alles eigentlich notwendig ist und warum das nicht auch anders geht. Ein Schritt in die richtige Richtung ist hier im Forum der FAQ- und Tutorial-Bereich. Doch auch dort musste ich feststellen, dass die Informationen z.T. recht alt oder unvollständig sind oder mehr Fragen aufwerfen, als sie beantworten.
Antworten
#2
Zuerstmal ein paar aktuelle Links:

TWRP 3.2.1-0 : https://forum.xda-developers.com/samsung...7-t3759214
LOS 14.1 : https://download.lineageos.org/a5y17lte
Odin : https://forum.xda-developers.com/showthr...?t=2711451
KIES USB-Treiber: https://developer.samsung.com/galaxy/oth...or-windows
(Sollte KIES schon installiert sein, unbedingt darauf achten, das KIES beendet ist!)

Ich persönlich bevorzuge die Installation von TWRP mittels Odin, wie sie im obigen Links beschrieben wird.
Dabei unbedingt darauf achten, das alle Häkchen mit Ausnahme von "F. Reset Time" entfernt sind.
Nach dem Flashen von TWRP, das Phone ausschalten, mind. 10 Sekunden warten und dann per "Lautstärke Lauter + Home + Power" griff, ins TWRP booten. (Den Powerknopf kann man im übrigen loslassen, wenn das Phone vibriert)

Als erstes fragte dan TWRP ob es dauerhaft installiert werden soll, was mit einem "Wischen" zu bestätigen ist.

Alles andere sollte dann nach Anleitung laufen.
Also Wipen von System, Data, Cache/Davlik
Installieren von LOS 14.1 und direkt danach, OHNE NEUSTART, die GApps und ggf. SUAddon.

Hoffe dies hilft Dir erstmal weiter.

Gruß
Antworten
[-] Die folgenden (1) User sagen reset Danke für diesen Beitrag:
Toloram (17.05.2018)
#3
Danke für die Infos.
Normalerweise sollte man davon ausgehen, dass die Infos und Links auf wiki.lineageos.org korrekt und aktuell sind. Weswegen dann auf eine alte (veraltete?) Version von TWRP verlinkt wird, erschließt sich mir nicht.
Jedenfalls habe ich die aktuelle Version (3.2.1-0) ohne Probleme (jedenfalls auf den ersten Blick) mit Odin installiert bekommen. Allerdings funktioniert alles weitere trotzdem nicht:
1. Das von dir erwähnte Ausschalten funktioniert nicht. Wenn ich im Download-Modus bin, ist ein Reset (mit VolumeDown + Power) das einzige was möglich ist. Danach startet sofort der Bootvorgang. Wenn ich schnell genug bin, kann ich noch ins Recovery starten, ansonsten hängt das Gerät im Boot-Loop.
2. Im Recovery wird anfangs eine Abfrage vorgeschaltet, ob TWRP lesend oder schreibend auf den Speicher zugreifen soll. Ich habe den Haken gesetzt, dass diese Abfrage nicht wieder angezeigt werden soll. Doch beim nächsten Start des Recovery erscheint diese Abfrage erneut.
3. Wipen ist nicht möglich, weil der Zugriff, bzw. Mounting der Speicherbereiche (Partitionen) als nicht möglich angezeigt wird.
4. Die einzelnen Speicher (Internal Storage, Micro SD card und USB OTG) werden alle mit 0 MB angezeigt.
5. Im Dateimanager wird mir eine größtenteils leere Verzeichnisstruktur angezeigt.

Es scheint so, als würde TWRP trotz Erlaubnis keinen Speicherzugriff bekommen.
Antworten
#4
https://forum.xda-developers.com/samsung...g-t3747535
Antworten
#5
(17.05.2018, 20:57)daywalk3r666 schrieb: https://forum.xda-developers.com/samsung...g-t3747535

Cool! Wenn das alles wahr ist, ist das eine Riesensauerei Angry 

Aber auch diesen Beitrag sollte man mit Vorsicht genießen. Mir sind auf Anhieb zwei Sachen aufgefallen, die so nicht ganz stimmen: Man muss nur 7 mal auf den Build-Eintrag tippen um die Entwickler-Optionen freizuschalten und nicht 10 mal, wie dort angegeben. Und aus dem Download-Modus komme ich nur mit VolumeDown + Power, in dem Beitrag ist zusätzlich noch die Home-Taste angegeben. Weiterhin wird dort von einer Wartezeit von 7 Tagen berichtet, in einer anderen Quelle habe ich allerdings von 72 Stunden gelesen - bloß was soll ich glauben?

Die Frage ist jetzt auch, habe ich diesen ominösen RMM-Lock oder nicht? Die Meldungen im Download-Modus lesen sich wie folgt:
Code:
ODIN MODE
DOWNLOAD SPEED: FAST
PRODUCT NAME: SM-A520F
CURRENT BINARY: Custom
SYSTEM STATUS: Custom
FRP LOCK: OFF
Secure Download : Enabled
CCIC =
WARRANTY VOID: 1 (0x020c)
RP SWREV: B:4 K:1 S:1
...
Danach ist weder RMM-Lock noch FRP-Lock aktiv, doch was könnte es noch sein?
Antworten
#6
dazu kann ich leider nix sagen.xda ist halt bei sowas die erste anlaufstelle

das du den interne sd und co net siehst ist normal.data ist verschlüsselt.um das zu ändern muss man format data ausführen.für system musst du am anfang modifikationen zu lassen.
so wars wenigstens früher bei samsung.k.a was die sich jetzt wieder einfallen lassen ham.

das teil hat net zufällig ein rausnehmbaren akku?
Antworten
#7
(18.05.2018, 08:19)daywalk3r666 schrieb: das teil hat net zufällig ein rausnehmbaren akku?

Nee, dann wär das ja auch zu einfach Big Grin
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Samsung A5 (SM-A520F) LineageOS 14.1 erkennt SIM-Karte nicht Collingwood 4 240 Gestern, 21:48
Letzter Beitrag: McNature
  [LineageOS] Kameraton beim S4 abstellen möglich? Schinkenhörnchen 1 302 27.07.2018, 20:18
Letzter Beitrag: InTheY2K
  [LineageOS] Fehler beim Kompilieren - Kernel für JF-Geräte greatogreat 3 621 22.12.2017, 19:36
Letzter Beitrag: Jesusnagler
  [LineageOS] samsung s4 mini (lte) probleme - insb. beim telefonieren okolib 1 812 06.10.2017, 02:15
Letzter Beitrag: DarkStar
  [LineageOS] Installationsprobleme Samsung Galaxy S5lte+ richie2686 3 864 13.09.2017, 16:42
Letzter Beitrag: zeudo

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste