Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] Installation nicht möglich
#1
Hallo Zusammen,

ich habe auf meinen nokia 6.1 TWRP 3.2.3.0 geflasht... Jetzt kann ich leider kein Lineage-18.1 installieren.
Die Meldung lautet einfach nur "Fehler beim Installieren von ZIP...

Kann mir dazu irgendjemand weiterelfen?

Viele Grüße
RalleA
Antworten
#2
Wenn alles richtig installiert ist und NUR "Fehler beim Installieren von ZIP..." erscheint liegt die Vermutung nahe
das der Download der Zip defekt ist.
Nach dem Download die Zip mit md5sum überprüft?
Oder NICHT die zu dem Device passende Custom-ROM downloaded?
Antworten
#3
Hallo db91595,

vielen Dank für die Hinweise. Ich hab den Download zumindest mit z-Zip geprüft und er ist OK. Das Gerät ist auch das richtige...

Hier mal die Meldungen aus dem LOG:

Digest-Prüfung übersprungen: keine Digest-Datei gefunden
I:AB zip
I:has_legacy_properties: Could not open /tmp/updater: No such file or directory!
I:Legacy property environment not used in updater.
Package is for product PL2,PL2_sprout,Plate2 but expected PL2
I:Install took 0 second(s).
Fehler beim Installieren von ZIP '/sdcard1/Download/lineage-18.1-20211109-nightly-PL2-signed.zip'
Partitions-Informationen werden aktualisiert...
IBig Grin 2ata backup size is 0MB, free: 20108MB.
I:Unable to mount '/usb-otg'
I:Actual block device: '', current file system: 'auto'

Viele Grüße und Danke
Antworten
#4
Ich hab jetzt noch etwas "festgestellt" es fehl die der Mount Point /cache. Wie kann ich den wiederherstellen?
Antworten
#5
Ich habe kein Nokia !!!
Ist das hier https://download.lineageos.org/PL2
dein Device?
Wenn es dein Device ist: den Download der Zip mit der dort angegebenen "sha256" gecheckt?

Wenn es dein Device ist die LOS-Install-Anleitung https://wiki.lineageos.org/devices/PL2/install

Für mich (da Nokia) pur "Theorie".
Mal schauen, ob hier jemand mit Nokia-Erfahrung noch rein schaut.

Edit: ich würde es mal mit dem LOS-Recoverie probieren. Siehe LOS-Install-Anleitung.
Es ist möglich das dein TWRP doch nicht "ganz" passt. (auch pur Theorie).

Edit2: gerade gesehen das wir unter Geräte kein Nokia haben.
Antworten
#6
Hallo db91595, das hab ich alles schon gemacht, leider hilft das im Moment alles nichts. Danke Trotzdem.
Antworten
#7
Hallo, RalleA,

du hättest geschrieben, dass du TWRP 3.2.3.0 geflasht hättest.
https://eu.dl.twrp.me/PL2/
Es gibt aber schon 3.3.1.0. vom 01.07.2020 - auch schon 14 Monate alt.
Das LOS-Recovery ist vom 16.11.2021, da würde ich dem den Vorgang geben.

Hier ist etwas exotisch: Im Forum von Xda-Developers gibt es den Austausch mit den Entwicklern. Für dein Telefon gibt es einen Thread für LOS 17.1,
https://forum.xda-developers.com/f/nokia...othe.7484/
aber keinen für 18.1???

Gruß,
wowi63
Antworten
#8
Das ist nicht exotisch. Der Entwickler bei LineageOS hat 18.1
Wie aktuell ein LOS ist hängt immer davon ab welcher Entwickler sich die Mühe macht und seine Freizeit dafür einsetzt.
Meistens wird da die Weiterentwicklung gestoppt wenn der Entwickler keine Lust mehr hat (andere Interessen; Phone verloren ...).
Antworten
#9
Hallo,

danke für die Tips. Ich habe in der Zwischenzeit die neuere Version von TWRP installiert und diese funktioniert.

Das Recovery funktioniert leider auch nicht.

Es scheinen die Partitionen defekt zu sein. Ich kann die Cache Partition nicht löschen oder widerherstellen.
Antworten
#10
Noch mal etwas Theorie zu Nokia.

Schau mal hier https://android.stackexchange.com/questi...-nokia-6-1
stackexchange.com ist (für mich) eine vertrauenswürdige Seite.

Ich würde mir (falls du es noch nicht gemacht hast) die letzte Firmware zu deinem Phone downloaden.
Diese nach der Anleitung (feinstes englisch; falls du kein english kannst die Anleitung im WWW übersetzen lassen)
als erstes damit die Firmware neu installieren. Das braucht man beim "fummeln" in der Firmware (Stock-ROM) eh immer um - falls was schief
geht - das Phone wieder in Stock-Zustand zu bekommen.
Dann nach LOS-Anleitung das LOS-Recovery installieren.
Dann das LOS installieren.
Wenn dabei kein Fehler auftritt - fertig.
Falls doch an einem Punkt ein Fehler auftritt kann man sich gezielt um diesen Fehler kümmern.

Wie ich es lese ist dein Phone in einem "unstabilen" Zustand. Da mit Reparatur-Versuchen die Zeit vergeuden halte ich für Zeitverschwendung.
Mein Motto: von einer funktionierenden Grundlage Schritt für Schritt weiter arbeiten.

"TWRP funktioniert / Recovery leider nicht"
TWRP (Team Windows Recovery Project = EIN Custom-Recovery mit dem eine Custom-ROM installiert werden KANN)
Wenn TWRP installiert wird ersetzt dieses das Stock-Recovery.
Bei LOS empfiehlt sich die Verwendung des LOS-Recovery. Das kommt ja vom Entwickler der LOS-ROM.
Da kann man davon ausgehen das es funktioniert.

Kurz: man sollte zumindest im Groben die Zusammenhänge verstehen. Oder eine Anleitung stur und pedantisch abarbeiten.
Ich schreibe das nicht um mich irgendwie ... sondern das ist meine Erfahrung.
Ich habe auch mal angefangen mit fast NULL Ahnung.
Deshalb: Firmware auf letzten aktuellen Stand bringen. Egal, was vorher installiert wurde, das Phone ist dann wieder brauchbar.
Die Firmware überplättet ALLES. Das Phone ist wie im "Verkaufs-Zustand" (wie neu).

Bei meinem Samsung kann man installieren was man will - so lange man noch in den Bootloader-Modus kommt kann man mit
Odin wieder das Stock-ROM installieren - Phone läuft.
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Nokia 6.1 Blitzlicht funktioniert nicht RalleA 0 52 Gestern, 20:13
Letzter Beitrag: RalleA
  Threema erkennt ext. SD Karte nicht georgy_boy 5 993 16.10.2021, 22:20
Letzter Beitrag: llluuuzzziii
  [LineageOS] Installation von LOS 18.1 auf Galaxy S5 (klte), startet nicht lalku 9 1.595 24.09.2021, 10:40
Letzter Beitrag: lalku
  [APP] Osmand mit LOS 17/18 ohne Gapps aktiviert GPS nicht Zamperl 39 9.478 30.07.2021, 16:16
Letzter Beitrag: WST61
  lizensiertes OSMAnd unter LOS18 läuft nicht wonk 7 1.547 29.07.2021, 15:23
Letzter Beitrag: llluuuzzziii

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste