Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Magisk und Magisk Manager verstehen sich nicht...
#1
Hallo alle,

Folgendes Setup:

- BQ Aquaris x mit offiziellem LOS 16
- Magisk 20.1
- Magisk Manager 7.4.0

Alles funzt wunderbar.

Aber: Magisk Manager meldet regelmäßig, dass Magisk nicht installiert sei. Das stimmt aber nicht. Ich habe Magisk 20.1 definitiv installiert.

Screenshot: siehe Anhang

Kennt jemand dieses Verhalten?

LG, gogol


Angehängte Dateien Thumbnail(s)
   
Antworten
#2
So wie es aussieht, hat es was mit dem Update zu tun:

Ich habe grad nochmal Magisk per ADB Sideload installiert. Dann zeigt mir der Magisk Manager an, dass Magisk installiert sei. Siehe Screenshot im Anhang. Danach habe ich das neue LOS-Update eingespielt (Dass ich täglich Updates angeboten bekomme, obwohl ich es auf "monatlich" eingestellt habe, ist nochmal eine andere Baustelle.) und der Magisk Manager zeigt mir an, dass Magisk nicht installiert sei. Siehe Screenshot.

Haut mir das LOS-Update jedes Mal Magisk raus? Muss ich Magisk dann jedes Mal neu installieren? Wäre komisch und ist sicher das normale Verhalten, oder?


Angehängte Dateien Thumbnail(s)
       
Antworten
#3
Es schein wirklich so zu sein, dass Magisk nach jedem OTA-Update neu geflasht werden muss: Da bei einem Update von LOS das Boot-Image überschrieben wird – und Magisk ja genau dort plaziert ist – wird das halt auch überschrieben.

Habe diese Quelle gefunden, wo auch ein Workarround per Script beschrieben wird:

https://www.antary.de/2018/09/08/welches...er-magisk/

Puhh, ganz schön aufwändig...

Naja, damit ist das für mich erstmal auf Eis gelegt.
Antworten
#4
Nein. Magisk bringt ein eigenes Script mit um OTA zu überleben.
Deine Installation ist vermutlich kaputt. Warum flasht Du Magisk.ZIP über adb sideload und nicht direkt im TWRP?

G900F mit LOS16
Antworten
#5
Hallo llluuuzzziii,

Zitat:Nein. Magisk bringt ein eigenes Script mit um OTA zu überleben.
Deine Installation ist vermutlich kaputt. Warum flasht Du Magisk.ZIP über adb sideload und nicht direkt im TWRP?

Die Anleitung, die ich gefunden habe, schlägt diese Vorgehensweise vor. Und die geht ja auch über TWRP:

- TWRP starten und das Gerät via USB mit dem Rechner verbinden
- Öffnet das Menü Advanced und tippt dort auf ADB Sideload
- Wischt einmal von links nach rechts über den Bildschirm und versetzt euer Gerät damit in den Sideload-Modus. Auf eurem Rechner wird die Übertragung über die Konsole / Kommandoeingabe gestartet: adb sideload Magisk-v20.1.zip

Quelle: https://www.kuketz-blog.de/magisk-bei-de...rol-teil3/

Meinst du, dass ich mir Magisk-v20.1.zip auf z.B. die externe SD-Karte des Telefons laden sollte und dann in TWRP installieren?
Antworten
#6
Habe das jetzt mal so gemacht:

Magisk auf die externe SD-Karte gespeichert.
Das Telefon im Recovery-Modus (TWRP) gestartet.
Dort mittels "installieren" die .zip-Datei intsalliert.
Dann den Magisk Manager als .apk-Datei installiert.

Nun wurde mir in der App sowohl Magisk als auch der Manager grün angezeigt: alles topp.

Dann habe ich zur Probe ein System-Update durchgeführt und bin so schlau wie zuvor: Magisk wird mir wieder als nicht installiert angezeigt...
Antworten
#7
Ups. Wie machst Du das Update? Automatisch im Updater?

G900F mit LOS16
Antworten
#8
Ich habe im Updater eigentlich "monatlich" eingestellt, werde aber trotzdem ständig auf die Nightly Builds hingewiesen. Ich stupse dann das Update nach Lust und Laune an.

Einstellungen -> System -> Erweitert -> Updater
Antworten
#9
Ist das bardockpro ein A/B-Device? Dann gucke mal ob das hier hilft

https://topjohnwu.github.io/Magisk/tutor...stallation

G900F mit LOS16
Antworten
#10
Ich habe dazu ein bissel gelesen: so wie es aussieht tritt der Fehler bei manchen Geräten auf. Gemeinsamkeit ist dann immer, daß die die beiden Installationsvarianten (sideload und flashable-Zip) mixen.
Ich würde an Deiner Stelle alles nochmal platt machen und sauber installieren. Das sideloading brauchst Du nur für TWRP! Danach wird direkt im TWRP geflasht!


G900F mit LOS16
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Sleep as Android - kennt sich jemand damit aus ? MingaCity 11 4.806 10.09.2019, 22:23
Letzter Beitrag: MingaCity
  Kamera kann nicht aus WhatsApp gestartet werden ed0red 11 12.798 28.08.2019, 16:12
Letzter Beitrag: janeloh
  AfWall lässt Shelter nicht raus osliner 2 1.896 18.07.2019, 07:16
Letzter Beitrag: osliner
  cLock auf Lineage OS V16 - Wetter läuft nicht tad-ulm 10 5.564 14.03.2019, 14:52
Letzter Beitrag: llluuuzzziii
  [APP] Hancom Office schließt sich direkt wieder und startet gar nicht erst richtig interessierter Newbie 3 3.140 15.09.2018, 12:17
Letzter Beitrag: llluuuzzziii

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste