Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Juchhu, mein Handy kommt nicht mehr hoch
#1
Sad 
In Supportforen soll man ja niemals "Hilfe" rufen, deswegen ruf ich jetzt mal: Juchhu, ich hab es geschafft, mein Handy kommt nicht mehr hoch. Nach der (Display-) PIN-Eingabe hängt es, überlegt sehr lange, zeigt dann nochmal die Kreise, die den Bootvorgang anzeigen und landet wieder in der PIN-Eingabe. Und so weiter. Es lässt sich auch nicht runterfahren, es landet immer wieder in der Schleife.
Ich hab es geschafft, mit adb reinzukommen und ein logcat gemacht: wie befürchtet, kommen die GooglePlayDienste sehr oft in dem logfile vor:
--------- beginning of crash
12-01 17:16:16.662  2234  2234 E AndroidRuntime: FATAL EXCEPTION: main
12-01 17:16:16.662  2234  2234 E AndroidRuntime: Process: com.google.android.gms.persistent, PID: 2234
12-01 17:16:16.662  2234  2234 E AndroidRuntime: DeadSystemException: The system died; earlier logs will point to the root cause
..... und täglich grüßt das Murmeltier
Bei den "earlier logs" kommt sehr oft ein "watchdog" vor, z.B. "Watchdog: *** WATCHDOG KILLING SYSTEM PROCESS" klingt unfreundlich.
Ich komme auch in TWRP (immerhin, wenn das Handy nicht mehr auf Tastendruck reagiert!), weiß aber nicht so genau, was ich dort machen kann, um aus der Misere rauszukommen.
Wie kam es zu dem Crash? Vielleicht bin ich nicht ganz unschuldig. Ich hab folgendes getan (eigentlich nix verbotenes):
 1. Ich hab fast alle Berechtigungen von GooglePlayDienste auf "immer nachfragen" gesetzt. "immer nachfragen" ist mein Lieblingsparameter, weil man dann nämlich erst mal sieht, wer alles wann was machen will.
 2. Ich entferne mein Google-Konto vom Smartphone. GPD fragt, ob es eine SMS versenden darf. Ich lehne das ab.
 3. Meine Kontakte sind wieder weg (das hat llluuuzzziii ja schon angedeutet, dass das mit dem Entfernen des Kontos zusammen hängt). Ich importiere die Kontakte wieder.
 4. Dann war ich so leichtsinnig, shut down zu machen, beim nächsten Booten trat das oben beschriebene Problem auf.
Ich hatte solche Situationen ja schon öfter. Wenn nix mehr half, hab ich die SIM-Karte entfernt, dann hat er sich beruhigt. Das hilft diesmal leider auch nicht mehr.

 Jetzt weiß ich gar nicht, was ich fragen soll. Hat jemand eine Idee, ob ich die Installation noch retten kann? Via adb oder TWRP? Oder geht es jetzt endgültig ab ins Clean-Kloster?
 Sibylla Delphica desperata Exclamation
Gott sei Dank hab ich noch mein altes S5.
Antworten
#2
Hilft Dir zwar jetzt nicht weiter, aber ich hatte 2x ähnliche Probleme mit Google-Play und musste das System jeweils neu installieren. Angeregt von Deinem Thread https://www.lineage-os-forum.de/Thread-G...hne-Google und weil mir das Theater einfach langsam zu blöd wurde, habe ich nun LOS ohne Gapps aufgesetzt mit F-Droid-Apps und fühle mich seitdem viel viel besser Big Grin 2 Als Belohnung gab es seitdem keinen Absturz mehr - läuft aber auch erst drei Tage.

Langer Rede kurzer Sinn: Das ist ein Wink aus Mountain View! Jetzt ist für Dich die beste Gelegenheit, Deine Lebensplanung (siehe Link oben) in die Tat umzusetzen. Deine Lebenszufriedenheit wird um mindestens 100% steigen - nur Mut Wink
Antworten
[-] Die folgenden (2) User sagen mali Danke für diesen Beitrag:
llluuuzzziii (02.12.2018), sibylla (01.12.2018)
#3
(01.12.2018, 22:19)mali schrieb: Hilft Dir zwar jetzt nicht weiter, aber ich hatte 2x ähnliche Probleme mit Google-Play und musste das System jeweils neu installieren. Angeregt von Deinem Thread https://www.lineage-os-forum.de/Thread-G...hne-Google und weil mir das Theater einfach langsam zu blöd wurde, habe ich nun LOS ohne Gapps aufgesetzt mit F-Droid-Apps und fühle mich seitdem viel viel besser Big Grin 2 Als Belohnung gab es seitdem keinen Absturz mehr - läuft aber auch erst drei Tage.

Langer Rede kurzer Sinn: Das ist ein Wink aus Mountain View! Jetzt ist für Dich die beste Gelegenheit, Deine Lebensplanung (siehe Link oben) in die Tat umzusetzen. Deine Lebenszufriedenheit wird um mindestens 100% steigen - nur Mut Wink

Doch, das hilft mir sehr wohl weiter. Ich muss mich nur endlich trauen. Danke für's Mut machen! Jetzt ist wirklich der beste Zeitpunkt, weil schlimmer kann's ja nicht mehr werden. Smile
Antworten
#4
Hi sibylla, du erträgst schon ganz schön Schmerzen nur wegen den Google-Diensten wenn man das so liest.

Ich kann dir sagen es geht ohne. Mache ich schon eine ganze Weile auf einem Wileyfox Swift unter LOS15.x.

Ich nutze F-Droid und wenn man doch mal was braucht was es da nicht gibt dann gibts die Yalp App aus F-Droid.

Ich kann dir die Empfehlungen des Herrn Kuketz empfehlen. --> https://www.kuketz-blog.de/empfehlungsecke/#android

Noch einige Sachen wie ich verschiedene Google Sachen ersetze:

- Kontakte: werden auf dem PC in Thunderbird gepflegt, mit dem MyPhone Explorer auf das Flachfon syncronisiert + gesichert
- Kalender: wird in der Regel auch im Thunderbird bearbeitet, von da mittels CalDAV zu meinem Mail-Anbieter, von da mit DAVdroid aus dem F-Droid auf Flachfon
- Mails: K9 aus F-Droid
- Messenger: Conversations aus F-Droid + Threema direkt vom Hersteller
- Navi/ Karten: OsmAnd aus F-Droid + MagicEarth über Yalp --> https://mobilsicher.de/kategorie/orten-n...er-favorit

Was gibts noch von Google was man ersetzen müsste?

Gruß
Antworten
#5
Vielleicht hilft der Tip: starte in TWRP, gehe zu /data/data/com.google.android.gms... und lösche die Ordner die dort drin sind (nicht den Ordner ...com.google.android.gms...!). Das sind die Einstellungen der PlayDienste selber. Eventuell hilft das?

G900F mit LOS 15
Antworten
#6
(02.12.2018, 01:43)uwe75 schrieb: Was gibts noch von Google was man ersetzen müsste?
Weiß jetzt nicht, ob mans ersetzen muss, aber:
Youtube > NewPipe
Antworten
#7
vielen Dank  an alle für die tollen Tipps und für die moralische Unterstützung!! Smile

Ich hab jetzt erst mal versucht, llluuuzzziii's Tipp zu befolgen, bevor ich alles platt mache. Dabei hab ich folgendes beobachtet:
Wenn ich auf meinem S5 LOS 14 in gebootetem lineage in die Dateimanager-App gehe, dann finde ich den Ordner com.google.android.gms unter SM-G900F/Android/data. Er enthält einen Unterordner "files", dieser enthält eine winzige jpg-Datei.

Wenn ich beim Xiaomi in TWRP bin und dort in den Filemanager gehe oder ins Terminal, dann lande ich in beiden Fällen im root-Verzeichnis eines Linuxverzeichnisses, so mit boot, dev, etc, init, .... und so. Das System bietet mir freundlicherweise ein "#" an. :-)  Aber das Verzeichnis data ist leer und auch das find-Kommando von / aus findet weit und breit kein com.google.android.gms. Das gleiche Bild erhalte ich über adb shell. Ich habe das Gefühl, dass ich da erst was mounten muss, aber was bloß ??? Confused
Antworten
#8
Du musst /data nach /data mounten ;o) zumindest beim S5. Wie Xiaomi die Partitionen nennt, weiß ich leider nicht.
Unter /proc/partitions findest Du alle Partitionen. Unter /proc/mounts siehst Du wohin die gemountet sind (WENN sie gemountet sind).

G900F mit LOS 15
Antworten
[-] Die folgenden (1) User sagen llluuuzzziii Danke für diesen Beitrag:
sibylla (03.12.2018)
#9
Man kann mir wirklich  nicht vorhalten, ich hätte es nicht versucht. Während meine Freundinnen Plätzchen backen, verbringe ich etliche Stunden meiner Freizeit im Kampf gegen die GooglePlayDienste.  Big Grin 2 
Zuerst versuche ich, IIIuuuzzziii's Tipp umzusetzen.
Das Mounten der data-Partition im Recovery hab ich leider nicht geschafft, weder unter dem Mount-Button des TWRP noch im TWRP-Terminal im Kommandomodus. Das könnte vielleicht damit zusammen hängen, dass xiaomi die Data-Partition verschlüsselt??? Also dachte ich, ich muss die Verzeichnisse im laufenden, in der Schleife rennenden Lineage löschen, denn Lineage kann die Partition ja mounten.
Ich boote also Lineage in die Schleife und gehe per adb in die root shell. Dort finde ich erwartungsgemäß das Verzeichnis /data/data/com.google.android.gms und lösche sämtliche Unterordner. So schnell kann ich gar nicht schauen, wie drei von den Unterordnern wieder da sind. Das Verhalten des Phones ist leider unverändert. Nun werde ich rabiat und kille (-9) die Prozesse com.google.android.gms und den  com.google.android.gms.persistent. (Das Gute an dem Zustand meines Phones ist, man wird völlig skrupellos und lässt alle Hemmungen fahren.) Doch auch das zeigt nicht die gewünschte Wirkung, das System läuft weiter in der Schleife, die Prozesse sind bald wieder da.
Nun habe ich keine Idee mehr.
Ich werde jetzt erst mal abtauchen und das Wiki für die Lineage-Installation wieder studieren ... Huh . Wenn aber noch jemand eine Idee hat, was ich noch löschen, killlen, ... könnte, ... immer gerne, ich hab ja jetzt eine gewisse Routine darin.
@llluuuzzziii: es hat zwar nicht geholfen, aber es hat mich dennoch weiter gebracht, ich habe wieder sehr viel gelernt. Danke dafür!
Sibylla
Antworten
#10
(03.12.2018, 14:03)sibylla schrieb: Man kann mir wirklich  nicht vorhalten, ich hätte es nicht versucht. Während meine Freundinnen Plätzchen backen, verbringe ich etliche Stunden meiner Freizeit im Kampf gegen die GooglePlayDienste.  Big Grin 2 
Zuerst versuche ich, IIIuuuzzziii's Tipp umzusetzen.
Das Mounten der data-Partition im Recovery hab ich leider nicht geschafft, weder unter dem Mount-Button des TWRP noch im TWRP-Terminal im Kommandomodus. Das könnte vielleicht damit zusammen hängen, dass xiaomi die Data-Partition verschlüsselt??? Also dachte ich, ich muss die Verzeichnisse im laufenden, in der Schleife rennenden Lineage löschen, denn Lineage kann die Partition ja mounten.
Ich boote also Lineage in die Schleife und gehe per adb in die root shell. Dort finde ich erwartungsgemäß das Verzeichnis /data/data/com.google.android.gms und lösche sämtliche Unterordner. So schnell kann ich gar nicht schauen, wie drei von den Unterordnern wieder da sind. Das Verhalten des Phones ist leider unverändert. Nun werde ich rabiat und kille (-9) die Prozesse com.google.android.gms und den  com.google.android.gms.persistent. (Das Gute an dem Zustand meines Phones ist, man wird völlig skrupellos und lässt alle Hemmungen fahren.) Doch auch das zeigt nicht die gewünschte Wirkung, das System läuft weiter in der Schleife, die Prozesse sind bald wieder da.
Nun habe ich keine Idee mehr.
Ich werde jetzt erst mal abtauchen und das Wiki für die Lineage-Installation wieder studieren ... Huh . Wenn aber noch jemand eine Idee hat, was ich noch löschen, killlen, ... könnte, ... immer gerne, ich hab ja jetzt eine gewisse Routine darin.
@llluuuzzziii: es hat zwar nicht geholfen, aber es hat mich dennoch weiter gebracht, ich habe wieder sehr viel gelernt. Danke dafür!
Sibylla

Hallo ich würde LOS komplett neu installieren, nur dann ohne Google Dienste.

Ich bin jetzt nicht so der Experte daher verbessert mich falls falsch.

- Ins TWRP booten
- in TWRP    Wipe..  System + Data + Cache + Dalvik

dann in TWRP LOS ohne Google neu installieren

gut ist

Gruß
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  LineageOS 15.1 Update Datei nicht gefundenWileyfox Swift Fahrradreifen 1 247 15.11.2018, 17:42
Letzter Beitrag: Fahrradreifen
  [LineageOS] Popup "Zugriff auf USB-Gerät gewähren?" kommt immer wieder mnmlcnsnt 0 430 29.07.2018, 13:51
Letzter Beitrag: mnmlcnsnt
  HTC a9 Startet Systhen nicht mehr.. Geht nur in den Boodloader Taunus76 53 4.013 27.05.2018, 14:39
Letzter Beitrag: Fourmusic
  MI5 - LOS15.1 Keine Daten mehr unter TWRP nach Update sugo71 5 914 28.04.2018, 20:39
Letzter Beitrag: Fuerstenwalder
  Akkuverbrauch ungewöhnlich hoch Jakob Menzen 2 653 26.11.2017, 04:23
Letzter Beitrag: DarkStar

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste