Hallo Gast, bitte registriere dich um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.

Wie soll ich meine Frage im LineageOS Forum posten?


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[LineageOS] Xperia L - nach Lineage 14: kein Root mehr, kein TWRP mehr, keine GoogleApps möglich
#1
Hallo!

Gleich vorweg: ich bin ein Neuling was Root/flashen/CustomROMs/... anbelangt.

Mein Ziel: Lineage OS 14 auf mein Sony Xperia L (C2105) zu bringen mit allen üblicherweise benötigten Funktionen (u.a. auch div. Google Apps)

Was bisher geschah:
  • adb und fastboot auf meinem Laptop (Win10) installiert
  • den Bootloader entsperrt -> Folge: endloser Bootloop
  • mit Flashtool (http://www.flashtool.net) eine original-FW wieder aufgespielt
  • das Xperia L gerootet (mit Towelroot)
  • TWRP aufgespielt (mit Recovery-Installer-1.8-XL)
  • Lineage OS (lineage-14.1-20170915-nightly-taoshan-signed) mit TWRP installiert
  • open_gapps-arm-7.1-nano mit TWRP eingespielt -> beim ersten Start dauernd Fehlermeldungen (App-Absturtz)
  • im Android-Recovery-mode (TWRP war verschwunden!) Systempartition gewiped
  • im Android-Recovery-mode via arb-sideload (Apply update) Lineage OS (14.1-20170915-nightly) erneut installiert (ohne GApps) -> funktioniert! Allerdings kein Root!
  • danach wollte ich einen Factory-Reset machen um GApps zu installieren, aber die Installation (via arb-sideload) schlägt laufend fehl.
nun meine Fragen:
  1. wie kriege ich die GApps doch noch zum Laufen?
  2. wie bekomme ich wieder zu TWRP im Recovery mode?
  3. wie kann ich mein Xperia L wieder rooten (Towelroot funktioniert nicht mehr darauf)?
Danke schon jetzt für Eure Unterstützung!
Br.St
Antworten
#2
Ist dein Droide ein "taoshan"? Du hast die Bezeichnung der nightlys nicht vollständig wiedergegeben.
https://wiki.lineageos.org/devices/taoshan

Bist du genau nach der offiziellen Anleitung vorgegangen?
https://wiki.lineageos.org/devices/taoshan/install

Aktuelles TWRP installiert?
https://eu.dl.twrp.me/taoshan/

Randnotiz:
OpenGApps müssen direkt nach der Installation von LOS, ohne reboot, geflasht werden. Ansonsten wird es nichts.
Um den Droiden zu rooten besser keine Lösung eines Drittanbieter nutzen. Die passende Datei findest du in den Extras auf der DL Seite von LOS. Das kann auch noch später nachgeholt werden.
https://download.lineageos.org/extras
Windoof 10 zickt oft bei den Treibern. Win 7 oder Linux (zB Ubuntu) machen idR weniger Probleme.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#3
(21.09.2017, 01:22)DarkStar schrieb: Ist dein Droide ein "taoshan"? Du hast die Bezeichnung der nightlys nicht vollständig wiedergegeben.
https://wiki.lineageos.org/devices/taoshan
Ja, hab es im Beitrag ergänzt.

(21.09.2017, 01:22)DarkStar schrieb: Bist du genau nach der offiziellen Anleitung vorgegangen?
https://wiki.lineageos.org/devices/taoshan/install
Soweit möglich, ja. (näheres bei den anderen Antworten)

(21.09.2017, 01:22)DarkStar schrieb: Aktuelles TWRP installiert?
https://eu.dl.twrp.me/taoshan/
War zuerst nicht möglich.
Code:
FAILED (remote: Command not allowed)
Hab das Xperia L dann mit towelroot gerootet. Dann klappte es entweder mit fastboot (wie in der Anleitung, oder mit Recovery-Installer-1.8-XL, das kann ich nicht mehr sicher sagen.
Jetzt hab ich wieder die gleiche Fehlermeldung.  Sad

(21.09.2017, 01:22)DarkStar schrieb: Randnotiz:
OpenGApps müssen direkt nach der Installation von LOS, ohne reboot, geflasht werden. Ansonsten wird es nichts.
Ja, hab ich auch so versucht, da kamen allerdings bei jedem Start dauernd Fehlermeldungen (App-Absturtz), sodass nichts weiterging.

(21.09.2017, 01:22)DarkStar schrieb: Um den Droiden zu rooten besser keine Lösung eines Drittanbieter nutzen. Die passende Datei findest du in den Extras auf der DL Seite von LOS. Das kann auch noch später nachgeholt werden.
https://download.lineageos.org/extras
OK. Wie gehe ich da vor? Via ADB-Sideload funktioniert es nur teilweise...

(21.09.2017, 01:22)DarkStar schrieb: Windoof 10 zickt oft bei den Treibern. Win 7 oder Linux (zB Ubuntu) machen idR weniger Probleme.
Das mit den Treiben hab ich hingekriegt, läuft alles. Außer dass ich nicht via Dateimanager aufs Telefon zugreifen kann, trotz USB-Debuging.
Könnte notfalls auf Linux Mint umsteigen.
Antworten
#4
(21.09.2017, 11:20)Br.St schrieb:
(21.09.2017, 01:22)DarkStar schrieb: Randnotiz:
OpenGApps müssen direkt nach der Installation von LOS, ohne reboot, geflasht werden. Ansonsten wird es nichts.
Ja, hab ich auch so versucht, da kamen allerdings bei jedem Start dauernd Fehlermeldungen (App-Absturtz), sodass nichts weiterging.
Die beschriebenen Symptome klingen aber schon sehr stark nach dem, was typischerweise passiert, wenn man nach der LOS-Installation das Telefon startet und danach erst die gapps flasht. Vielleicht fängst Du noch mal frisch von vorne an. TWRP hast Du jetzt drauf? Dann nochmal beide ZIPs auswählen (erst LOS, dann gapps) und Installation starten. Danach Cache/Dalvik wipen und dann Telefon booten.

(21.09.2017, 11:20)Br.St schrieb:
(21.09.2017, 01:22)DarkStar schrieb: Um den Droiden zu rooten besser keine Lösung eines Drittanbieter nutzen. Die passende Datei findest du in den Extras auf der DL Seite von LOS. Das kann auch noch später nachgeholt werden.
https://download.lineageos.org/extras
OK. Wie gehe ich da vor? Via ADB-Sideload funktioniert es nur teilweise...
Wenn alles läuft, ganz einfach das SU-Addon separat herunterladen und flashen. Kann man jederzeit auch wieder rückgängig machen mit dem "Remove SU"-Gegenpart.

Gruß
Sascha
Antworten
#5
Zitat:TWRP hast Du jetzt drauf? 
Leider nicht, und ich hab auch keinen Plan mehr wie ich die raufkriege...  Confused komme nur ins "normale" Adroid-Recovery....
Antworten
#6
Arbeite dich noch einmal von vorne durch die Anleitung. Wenn dann was hakt stimmt mit Set und Setting etwas nicht. Am zuverlässigsten läuft es unter Win 7. PC vom Kumpel, auf anderer Festplatte ein W7 für solche Aktionen etc.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#7
Ich würde die tollen flash/root programme lassen und es "richtig" über fastboot machen.

Wenn der bootloader entsperrt ist sollte das kein Problem sein.

In dein Platform Tools Ordner (Platform Tools installieren m über ADB siehe Google)) gehen+Shift+ rechte Maustaste "Eingabe Aufforderung hier öffnen" oder so

Dann
fastboot devices ( wenn da was kommt erkennt es das)

fastboot flash recovery twrp_xxxx.img (bei den xxx natürlich den richtigen TWRP Dateinamen eingeben)

fastboot flash boot.img (somit sollte die richtige lineageos Partition eingerichtet werden)

Danach ins Recovery booten, full wipe, flash Rom, flash gapps, restart system



Sent from my ONEPLUS A3003 using CyanogenMod Forum mobile app
Antworten
#8
(21.09.2017, 13:01)DarkStar schrieb: Arbeite dich noch einmal von vorne durch die Anleitung. Wenn dann was hakt stimmt mit Set und Setting etwas nicht. Am zuverlässigsten läuft es unter Win 7. PC vom Kumpel, auf anderer Festplatte ein W7 für solche Aktionen etc. 
OK. Win7 hab ich leider nicht so einfach zur Hand.

Hab's soeben mit Linux von Anfang an probiert:

Bootloader unlock: OK
Reboot: OK (es läuft das bereits installierte Lineage14)
USB-Debugging neu erlaubt.
TWRP installiert: Error!
Dann auf Windows probiert, ebenso derFehler:
Code:
C:\>fastboot flash recovery twrp-3.0.2-0-taoshan.img
target didn't report max-download-size
sending 'recovery' (11276 KB)...
OKAY [  0.391s]
writing 'recovery'...
FAILED (remote: Command not allowed)
finished. total time: 0.391s
Antworten
#9
Sicher dass es mit Linux war? C:\ ist Windoof, müsste in dem Fall # sein. Wink

Wenn mit Linux dann auch (wie auf Win) als Admin ausführen.

Sent from my MotoG3 using CyanogenMod Forum mobile app
Antworten
#10
(21.09.2017, 22:01)DarkStar schrieb: Sicher dass es mit Linux war? C:\ ist Windoof, müsste in dem Fall # sein. Wink

Wenn mit Linux dann auch (wie auf Win) als Admin ausführen. 

Ja natürlich. Hab es dann nur nochmals auf Windows probiert und mit dann gleich den Fehlercode kopiert. Kann dir aber gerne einen Screenshot schicken, wenn Du es mir nicht glaubst.  Wink

In Linux war's auch als Root-Benutzer.
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Sony Xperia Z erhalten Unterstützung Harmony 2 298 17.10.2018, 09:42
Letzter Beitrag: Harmony
  [LineageOS] Xperia xa2 15.1 schwendke 1 465 24.09.2018, 09:10
Letzter Beitrag: reset
  Xperia z3 TWRP - Lineage OS 14.1 BloodSickness 3 986 27.02.2018, 22:50
Letzter Beitrag: Jesusnagler
  [LineageOS] Sony TabletZ Pollux LTE wird von TWRP nur a Lineage update als Pollux Windy erkannt Flatulenzius 8 1.134 25.02.2018, 21:44
Letzter Beitrag: Flatulenzius
  Xperia L Stable CM/LineageOS? modestax 6 1.076 24.10.2017, 07:29
Letzter Beitrag: modestax

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste