Hey, bitte registriere dich, um alle Funktionen nutzen zu können!

Mach's gut, CyanogenMod. Hallo LineageOS. ♥ Unsere Community freut sich auf die neue Ära.


Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Sony Xperia XA2 19.1 - Bootloop nach Update auf 20221117
#1
Exclamation 
Hi, ich habe heute früh den "Fehler" gemacht mein Smartphone auf die neueste LAOS zu heben. Leider hänge ich seither in einer Bootloop, wo die gewohnte Ladeanimation von Lineage kommt, diese aber sich nie zum Schriftzug "LineageOS" aufbaut, sondern stattdessen das phone neustartet.

Ich hatte das Update mit dem Updater durchgeführt, weshalb ich annahm, dass es da vlt. Probleme gab. Also habe ich schon probiert die passende .zip aus dem Discovery Zweig per SD Karte und im Recovery modus einzuspielen. Das funktioniert zwar erfolgreich (im Gegensatz zum adb sideload, der bei 47% stecken bleibt), aber die boot loop bleibt trotzdem.

Mir ist aufgefallen, dass er danach von Slot B auf Slot A gewechselt ist. Im recovery log konnte ich erstmal nichts spannendes lesen, aber er kommt da nur bis zum WLAN (?) .
Ein downgrade auf die Version 20221019-microG-discovery.zip wird aber mit Error im recovery abgelehnt, weil das ja eine ältere Version ist.
Ich würde nur sehr ungern ein Facory reset durchführen, muss aber zugeben, dass ich gerade echt sehr verzweifel t bin Exclamation
Würde mich total freuen, falls ihr noch Ideen habt ...
Antworten
#2
Schau mal in https://www.lineage-os-forum.de/Thread-S...#pid146853
Vlt. findest du dort Info's die dir weiter helfen.
Zu install LOS: welches Recovery hattest du installiert - TWRP oder Lineage-Recovery?
War das "neue" LOS ein Update oder ein Upgrade? Da kann es Unterschiede im "WIE" geben. Deshalb in der Anleitung auf die Details achten.
Und es ist immer hilfreich ZUERST Info zu geben
- welches LOS (Link: woher)
- was war vorher installiert
Antworten
#3
Hi, entschuldige dass ich da so sparsam mit Details war.
Ich nutze das LAOS von microg ohne GAPPS, wo einige defaults anders gesetzt sind. Ich hatte ein Update vom laufenden lineage-19.1-20221019-microG-discovery
zu lineage-19.1-20221117-microG-discovery mit dem Updater im laufenden OS gemacht. Ich war ja schon länger auf dem LAOS und hatte bisher immer keine  Probleme, wenn ich das einfach über den Updater mache.

Ich nutze das LAOS eigene recovery

Eigentlich dachte ich, dass downgraden immer möglich sei, weshalb ich da auch immer recht nahe am upstream war. Habe ich da einen Denkfehler und zurück auf eine niedrigere Version geht gar nicht? Besteht eine Möglichkeit, dass ich vor dem wipe sonst zumindest meine Daten / Einstellungen abziehe und dann wieder zurückspiele? (Sorry, meine letzten ADB Experimente sind leider schon etwas her ... als ich das Phone einrichtete...).
Antworten
#4
Leider scheitere ich daran mal das Kernel log zu ziehen. Nachdem er den boot durch Neustart abgebrochen hat, habe ich ihn in das recovery gezwungen und adb aktiivert. Danach bekomme ich aber nur das:
Code:
adb shell cat /proc/last_kmsg > kmsg.txt

cat: /proc/last_kmsg: No such file or directory
Antworten
#5
Ebenfalls sorry! :-)
Was ist LAOS? Oder meinst du LOS (LineageOS)
Anhand deines Link sehe ich "LOS with microG".

Kann es sein das du noch das LOS-Recovery von 18.1 drauf hast?
Zu LOS 19.1 gibt es ein neueres: lineage-19.1-20221115-microG-discovery-recovery.img
Antworten
#6
Hi, danke für das Feedback! Genau es heißt ja LOS, irgendwie war ich auf der anderen Abkürzung hängen geblieben ;-)

Stimmt das Revocery war ja auch separat, das könnte tatsächlich älter gewesen sein, deshalb habe ich es mal angehoben:

Code:
$ adb reboot fastboot
$ sudo fastboot devices
CQ3000DAG8 fastboot
$ sudo fastboot getvar current-slot
current-slot: _a
finished. total time: 0.001s
$ sudo fastboot flash boot ~/Downloads/lineage-19.1-20221115-microG-discovery-recovery.img
target reported max download size of 536870912 bytes
sending 'boot_a' (24705 KB)...
OKAY [  0.953s]
writing 'boot_a'...
OKAY [  0.001s]
finished. total time: 0.954s
$ sudo fastboot reboot

Das scheint also geklappt zu haben (Slot A ist auch laut recovery aktiv), aber weder downgrade (denying OTA because it's SPL downgrade) und es bleibt bei meinem Problem mit kmsg.
Das neue LOS habe ich damit auch noch einmal eingespielt, aber da gab es auch keine Veränderung. Ich hänge in meiner boot loop Dodgy
Gibt es vielleicht noch eine Möglichkeit die logs auszulesen, um raus zu bekommen wo er stecken bleibt und neu startet? Das logcat will bei mir einfach nicht klappen (Waiting for device), funktioniert das evtl. nur bei einem laufenden Android für die syslogs?
Antworten
#7
Sorry - verstehe ich nicht.
"fastboot flash boot recovery.img"
Du flashst in die boot-partition das recovery.img?
Schreibfehler oder Denkfehler?
Das Recovery.img gehört in die Recovery-Partition.
Da das XA 2 ein A/B device ist
"fastboot flash recovery_a recovery.img"
und
"fastboot flash recovery_b recovery.img"

Du brauchst aus der Firmware noch das original "boot.img".
Das muss mit
"fastboot flash boot_a boot.img"
und
"fastboot flash boot_b boot.img"
noch geflasht werden.
Dann kann das Phone in den Recovery-Mode gebootet werden und mit Install Los.zip wieder ins LOS booten.
Antworten
#8
Hmm, wahrscheinlich fehlt mir da einfach das Hintergrundwissen. Da fastboot flash recovery ... bei mir nicht funktionierte, hatte ich etwas weitergelesen das es keine recovery Partition haben soll.
Die Recovery Partition hält die LOS recovery Tool, oder? (das sichere Flashen wird ja über A/B realisiert?)

Ich fand leider auch noch keinen weg, da die Namen der Partitionen zu bekommen. Mit adb klappte es leider nicht.
Da ich gerade an einem anderen Laptop sitze, kann das nicht wirklich von fehlenden Berechtigungen kommen, oder?
Code:
$ fastboot flash recovery_a losrecovery.img
Sending 'recovery_a' (24705 KB)                    OKAY [  0.884s]
Writing 'recovery_a'                               FAILED (remote: 'Command not authenticated')
fastboot: error: Command failed
$ fastboot flash recovery losrecovery.img
Sending 'recovery' (24705 KB)                      OKAY [  0.893s]
Writing 'recovery'                                 FAILED (remote: 'Command not authenticated')
fastboot: error: Command failed

Was wäre denn das boot.img welches du erwähntest? Ist das der Bootloader (der ja eigentlich bei mir funktioniert) und wo bekommt man diese Datei her?

P.S: Ist dir ein Weg bekannt, mit dem ich erst einmal alle Daten noch vom Smartphone sichern könnte? Ich habe etwas bammel bei den Partitionen, dass mir wirklich noch etwas verloren geht Undecided
Antworten
#9
Ich habe noch einmal nachgeschaut, bei meinem Phone ist das wirklich boot_a / boot_b für das recovery system (siehe Wiki). Auch das abgleich-Skript habe ich noch einmal ausgeführt, aber das hat leider nichts geholfen.
Antworten
#10
Konnte es dadurch lösen, dass ich die passende offizielle LOS Version eingespielt habe.
Laut offiziellen Chat kann es bei dem fork manchmal vorkommen, dass z.B. firmware fehlt.

Vielen Dank trotzdem für den Support!
Antworten



Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [LineageOS] Hilfe! Sony xz2c bootloop nach Update Marlenexz2c 6 628 22.11.2022, 19:40
Letzter Beitrag: Marlenexz2c
  Apps haben kein Internet | Sony Xperia Z5 | Lineage 18.1 Mediasocfan 0 1.005 05.06.2022, 18:38
Letzter Beitrag: Mediasocfan
  Lineage OS Installation Xperia 10 -> Bootloop -> Bootlock Geronimo 8 6.756 19.05.2022, 11:14
Letzter Beitrag: db91595
  Zeigt keine Speichermedien im Explorer nach Lineage-Installation plexa 16 5.751 09.12.2021, 16:33
Letzter Beitrag: db91595
  Xperia XA2 (H3113) - Kein Dienst knofi69 1 1.949 18.10.2021, 16:36
Letzter Beitrag: llluuuzzziii

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste